summaryrefslogtreecommitdiffstats
path: root/tags/cpp-1.0-incubating-M2-RC3/sca/runtime/extensions/ruby/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tags/cpp-1.0-incubating-M2-RC3/sca/runtime/extensions/ruby/src/Makefile.am')
-rw-r--r--tags/cpp-1.0-incubating-M2-RC3/sca/runtime/extensions/ruby/src/Makefile.am54
1 files changed, 0 insertions, 54 deletions
diff --git a/tags/cpp-1.0-incubating-M2-RC3/sca/runtime/extensions/ruby/src/Makefile.am b/tags/cpp-1.0-incubating-M2-RC3/sca/runtime/extensions/ruby/src/Makefile.am
deleted file mode 100644
index d73ac1f90c..0000000000
--- a/tags/cpp-1.0-incubating-M2-RC3/sca/runtime/extensions/ruby/src/Makefile.am
+++ /dev/null
@@ -1,54 +0,0 @@
-# Licensed to the Apache Software Foundation (ASF) under one
-# or more contributor license agreements. See the NOTICE file
-# distributed with this work for additional information
-# regarding copyright ownership. The ASF licenses this file
-# to you under the Apache License, Version 2.0 (the
-# "License"); you may not use this file except in compliance
-# with the License. You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing,
-# software distributed under the License is distributed on an
-# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
-# KIND, either express or implied. See the License for the
-# specific language governing permissions and limitations
-# under the License.
-
-libdir=$(prefix)/extensions/ruby/lib
-lib_LTLIBRARIES = libtuscany_sca_ruby.la
-
-install-exec-hook:
- cd $(libdir); \
- ln -s -f libtuscany_sca_ruby.so tuscany_sca_ruby.so; \
- for i in libtuscany_sca_ruby.*; do mv $$i $$i.disabled; done
-
-rootdir=$(prefix)/extensions/ruby
-root_SCRIPTS = deploy.sh
-
-noinst_HEADERS = \
-tuscany/sca/ruby/*.h \
-tuscany/sca/ruby/model/*.h
-
-EXTRA_DIST = deploy.sh
-
-libtuscany_sca_ruby_la_SOURCES = \
-tuscany/sca/ruby/RubyExtension.cpp \
-tuscany/sca/ruby/RubyImplementationExtension.cpp \
-tuscany/sca/ruby/RubyServiceProxy.cpp \
-tuscany/sca/ruby/RubyServiceWrapper.cpp \
-tuscany/sca/ruby/model/RubyImplementation.cpp \
-tuscany/sca/ruby/model/RubyReferenceBinding.cpp \
-tuscany/sca/ruby/model/RubyServiceBinding.cpp \
-tuscany/sca/ruby/RubyCompositeContext.cpp
-
-libtuscany_sca_ruby_la_LIBADD = -L${TUSCANY_SDOCPP}/lib -ltuscany_sdo \
- -L$(top_builddir)/runtime/core/src -ltuscany_sca \
- -L${RUBY_LIB} -lruby
-
-INCLUDES = -Imodel -I$(top_builddir)/runtime/core/src \
- -I${TUSCANY_SDOCPP}/include \
- -I${RUBY_INCLUDE}
-
-AM_CPPFLAGS = $(CPPFLAGS) -D_DEBUG
- \ No newline at end of file