summaryrefslogtreecommitdiffstats
path: root/sdo-cpp/trunk/samples/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'sdo-cpp/trunk/samples/configure.ac')
-rw-r--r--sdo-cpp/trunk/samples/configure.ac73
1 files changed, 73 insertions, 0 deletions
diff --git a/sdo-cpp/trunk/samples/configure.ac b/sdo-cpp/trunk/samples/configure.ac
new file mode 100644
index 0000000000..a2b0b9ef87
--- /dev/null
+++ b/sdo-cpp/trunk/samples/configure.ac
@@ -0,0 +1,73 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+dnl run autogen.sh to generate the configure script.
+
+AC_PREREQ(2.59)
+AC_INIT(tuscany-sdo-samples, 1.0-M3)
+AC_CANONICAL_SYSTEM
+AM_CONFIG_HEADER(config.h)
+AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
+AC_PREFIX_DEFAULT(/usr/local/tuscany/sdo/samples)
+
+# Checks for programs.
+AC_PROG_CXX
+AC_PROG_CC
+AC_PROG_CPP
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
+AC_PROG_LIBTOOL
+
+# Check for running on Darwin
+AC_MSG_CHECKING([Checking if running on Darwin])
+UNAME=`uname -s`
+if test "x$UNAME" = "xDarwin"; then
+ AC_DEFINE([IS_DARWIN], [1], [Set to 1 when running on Darwin - Mac OSX])
+ AC_MSG_RESULT(yes)
+ AC_SUBST([libsuffix],[".dylib"])
+ is_darwin=true
+else
+ AC_MSG_RESULT(no)
+ AC_SUBST([libsuffix],[".so"])
+ is_darwin=false
+fi
+AM_CONDITIONAL([DARWIN], [test x$is_darmin = xtrue])
+
+# Configure TUSCANY_SDOCPP
+TUSCANY_SDOCPP=`echo "$TUSCANY_SDOCPP"`
+if test "x$TUSCANY_SDOCPP" = "x"; then
+ SDOPWD=`pwd`
+ AC_SUBST([TUSCANY_SDOCPP], ["$SDOPWD/.."])
+fi
+
+# Configure LIBXML2_INCLUDE and LIBXML2_LIB
+LIBXML2_INCLUDE=`echo "$LIBXML2_INCLUDE"`
+if test "x$LIBXML2_INCLUDE" = "x"; then
+ AC_SUBST([LIBXML2_INCLUDE], ["/usr/include/libxml2"])
+fi
+
+LIBXML2_LIB=`echo "$LIBXML2_LIB"`
+if test "x$LIBXML2_LIB" = "x"; then
+ AC_SUBST([LIBXML2_LIB], ["/usr/lib"])
+fi
+
+AC_CONFIG_FILES([Makefile
+ misc/Makefile
+ ])
+AC_OUTPUT
+