summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/components/sqldb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sca-cpp/trunk/components/sqldb/Makefile.am')
-rw-r--r--sca-cpp/trunk/components/sqldb/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/sca-cpp/trunk/components/sqldb/Makefile.am b/sca-cpp/trunk/components/sqldb/Makefile.am
new file mode 100644
index 0000000000..0bea7b5eb1
--- /dev/null
+++ b/sca-cpp/trunk/components/sqldb/Makefile.am
@@ -0,0 +1,43 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+if WANT_SQLDB
+
+INCLUDES = -I${PGSQL_INCLUDE}
+
+#comp_SCRIPTS = pgsql-start pgsql-stop
+compdir=$(prefix)/components/sqldb
+
+comp_DATA = pgsql.prefix
+pgsql.prefix: $(top_builddir)/config.status
+ echo ${PGSQL_PREFIX} >pgsql.prefix
+
+#comp_LTLIBRARIES = libsqldb.la libqueue-listener.la
+
+#libsqldb_la_SOURCES = sqldb.cpp
+#libsqldb_la_LDFLAGS = -L${PGSQL_LIB} -R${PGSQL_LIB} -lpgsql
+
+#pgsql_test_SOURCES = pgsql-test.cpp
+#pgsql_test_LDFLAGS = -L${PGSQL_LIB} -R${PGSQL_LIB} -lpgsql
+
+#client_test_SOURCES = client-test.cpp
+#client_test_LDFLAGS = -lxml2 -lcurl -lmozjs
+
+#noinst_PROGRAMS = pgsql-test client-test
+#TESTS = sql-test server-test
+
+endif