summaryrefslogtreecommitdiffstats
path: root/sca-cpp/tags/native-sca-1.0.incubating-M3/runtime/extensions/ruby/extension/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sca-cpp/tags/native-sca-1.0.incubating-M3/runtime/extensions/ruby/extension/Makefile.am')
-rw-r--r--sca-cpp/tags/native-sca-1.0.incubating-M3/runtime/extensions/ruby/extension/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/sca-cpp/tags/native-sca-1.0.incubating-M3/runtime/extensions/ruby/extension/Makefile.am b/sca-cpp/tags/native-sca-1.0.incubating-M3/runtime/extensions/ruby/extension/Makefile.am
new file mode 100644
index 0000000000..41ce75925b
--- /dev/null
+++ b/sca-cpp/tags/native-sca-1.0.incubating-M3/runtime/extensions/ruby/extension/Makefile.am
@@ -0,0 +1,34 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+SUBDIRS =
+
+libdir=$(prefix)/extensions/ruby/lib
+BUILT_SOURCES = extension_build
+
+EXTRA_DIST = src
+
+extension_build: src/Extension.cpp src/extconf.rb
+ cd src; ruby extconf.rb; make
+ touch extension_build
+
+clean:
+ cd src;make clean
+ rm -f extension_build
+
+install-exec-hook:
+ cp src/tuscany_sca_ruby.* $(libdir)
+