summaryrefslogtreecommitdiffstats
path: root/java/sdo/sdo-api/pom.xml
diff options
context:
space:
mode:
Diffstat (limited to 'java/sdo/sdo-api/pom.xml')
-rw-r--r--java/sdo/sdo-api/pom.xml145
1 files changed, 0 insertions, 145 deletions
diff --git a/java/sdo/sdo-api/pom.xml b/java/sdo/sdo-api/pom.xml
deleted file mode 100644
index 6d66d4534d..0000000000
--- a/java/sdo/sdo-api/pom.xml
+++ /dev/null
@@ -1,145 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!--
- * Licensed to the Apache Software Foundation (ASF) under one
- * or more contributor license agreements. See the NOTICE file
- * distributed with this work for additional information
- * regarding copyright ownership. The ASF licenses this file
- * to you under the Apache License, Version 2.0 (the
- * "License"); you may not use this file except in compliance
- * with the License. You may obtain a copy of the License at
- *
- * http://www.apache.org/licenses/LICENSE-2.0
- *
- * Unless required by applicable law or agreed to in writing,
- * software distributed under the License is distributed on an
- * "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
- * KIND, either express or implied. See the License for the
- * specific language governing permissions and limitations
- * under the License.
--->
-<project>
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.apache</groupId>
- <artifactId>apache</artifactId>
- <version>4</version>
- </parent>
- <groupId>org.apache.tuscany.sdo</groupId>
- <artifactId>tuscany-sdo-api-r${specVersion}</artifactId>
- <packaging>jar</packaging>
- <version>1.2-SNAPSHOT</version>
- <name>SDO API</name>
- <description>API classes for Service Data Objects</description>
-
- <properties>
- <specVersion>2.1</specVersion>
- </properties>
-
- <!-- definition of repositories where the parent pom can be found -->
- <repositories>
- <repository>
- <id>apache.snapshots</id>
- <name>Apache Snapshot Repository</name>
- <url>http://people.apache.org/repo/m2-snapshot-repository</url>
- <releases>
- <enabled>false</enabled>
- </releases>
- <snapshots>
- <enabled>true</enabled>
- </snapshots>
- </repository>
-
- </repositories>
-
- <dependencies>
- <dependency>
- <groupId>junit</groupId>
- <artifactId>junit</artifactId>
- <version>4.3.1</version>
- <scope>test</scope>
- </dependency>
- </dependencies>
-
- <build>
- <plugins>
- <plugin>
- <groupId>org.apache.maven.plugins</groupId>
- <artifactId>maven-surefire-plugin</artifactId>
- <version>2.3</version>
- <configuration>
- <includes>
- <include>**/*TestCase.java</include>
- </includes>
- <reportFormat>brief</reportFormat>
- <useFile>false</useFile>
- <forkMode>once</forkMode>
- <argLine>-ea</argLine>
- </configuration>
- </plugin>
-
- <plugin>
- <groupId>org.apache.maven.plugins</groupId>
- <artifactId>maven-compiler-plugin</artifactId>
- <configuration>
- <source>1.4</source>
- <target>1.4</target>
- </configuration>
- </plugin>
- <plugin>
- <artifactId>maven-jar-plugin</artifactId>
- <configuration>
- <archive>
- <manifestFile>${project.build.outputDirectory}/META-INF/MANIFEST.MF</manifestFile>
- </archive>
- </configuration>
- </plugin>
- <plugin>
- <groupId>org.apache.felix</groupId>
- <artifactId>maven-bundle-plugin</artifactId>
- <version>1.4.0</version>
- <extensions>true</extensions>
- <executions>
- <execution>
- <id>bundle-manifest</id>
- <phase>process-classes</phase>
- <goals>
- <goal>manifest</goal>
- </goals>
- </execution>
- </executions>
- <configuration>
- <instructions>
- <Bundle-Name>${pom.name}</Bundle-Name>
- <Bundle-Version>${specVersion}</Bundle-Version>
- <Bundle-Description>${pom.description}</Bundle-Description>
- <Bundle-Vendor>${pom.organization.name}</Bundle-Vendor>
- <Bundle-Localization>plugin</Bundle-Localization>
- <Bundle-SymbolicName>org.apache.tuscany.sdo.spec</Bundle-SymbolicName>
- <Export-Package>
- commonj.sdo;version="${specVersion}", commonj.sdo.helper;version="${specVersion}",
- commonj.sdo.impl;version="${specVersion}"
- </Export-Package>
- </instructions>
- </configuration>
- </plugin>
- <plugin>
- <groupId>org.apache.maven.plugins</groupId>
- <artifactId>maven-javadoc-plugin</artifactId>
- <version>2.2</version>
- <configuration>
- <version>2.0</version>
- </configuration>
- <executions>
- <execution>
- <id>package</id>
- <phase>package</phase>
- <goals>
- <goal>jar</goal>
- </goals>
- </execution>
- </executions>
- </plugin>
- </plugins>
- <defaultGoal>install</defaultGoal>
- </build>
-</project>