summaryrefslogtreecommitdiffstats
path: root/java/sdo/impl/pom.xml
diff options
context:
space:
mode:
Diffstat (limited to 'java/sdo/impl/pom.xml')
-rw-r--r--java/sdo/impl/pom.xml189
1 files changed, 0 insertions, 189 deletions
diff --git a/java/sdo/impl/pom.xml b/java/sdo/impl/pom.xml
deleted file mode 100644
index 736bcb6e64..0000000000
--- a/java/sdo/impl/pom.xml
+++ /dev/null
@@ -1,189 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!--
- * Licensed to the Apache Software Foundation (ASF) under one
- * or more contributor license agreements. See the NOTICE file
- * distributed with this work for additional information
- * regarding copyright ownership. The ASF licenses this file
- * to you under the Apache License, Version 2.0 (the
- * "License"); you may not use this file except in compliance
- * with the License. You may obtain a copy of the License at
- *
- * http://www.apache.org/licenses/LICENSE-2.0
- *
- * Unless required by applicable law or agreed to in writing,
- * software distributed under the License is distributed on an
- * "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
- * KIND, either express or implied. See the License for the
- * specific language governing permissions and limitations
- * under the License.
--->
-<project>
- <parent>
- <groupId>org.apache.tuscany.sdo</groupId>
- <artifactId>tuscany-sdo</artifactId>
- <version>1.2-SNAPSHOT</version>
- </parent>
- <modelVersion>4.0.0</modelVersion>
- <artifactId>tuscany-sdo-impl</artifactId>
- <name>Tuscany SDO Implementation</name>
- <description>Tuscany implementation of SDO API.</description>
-
- <repositories>
- <repository>
- <id>codehaus</id>
- <name>Codehaus maven repository</name>
- <url>http://repository.codehaus.org/</url>
- </repository>
- </repositories>
-
- <dependencies>
- <dependency>
- <groupId>org.apache.tuscany.sdo</groupId>
- <artifactId>tuscany-sdo-lib</artifactId>
- <version>${sdo.version}</version>
- <scope>compile</scope>
- </dependency>
-
- <dependency>
- <groupId>org.eclipse.emf</groupId>
- <artifactId>common</artifactId>
- <version>${emfVersion}</version>
- <scope>compile</scope>
- </dependency>
- <dependency>
- <groupId>org.eclipse.emf</groupId>
- <artifactId>ecore</artifactId>
- <version>${emfVersion}</version>
- <scope>compile</scope>
- </dependency>
- <dependency>
- <groupId>org.eclipse.emf</groupId>
- <artifactId>ecore-change</artifactId>
- <version>${emfVersion}</version>
- <scope>compile</scope>
- </dependency>
- <dependency>
- <groupId>org.eclipse.emf</groupId>
- <artifactId>ecore-xmi</artifactId>
- <version>${emfVersion}</version>
- <scope>compile</scope>
- </dependency>
- <dependency>
- <groupId>org.eclipse.xsd</groupId>
- <artifactId>xsd</artifactId>
- <version>${emfVersion}</version>
- <scope>compile</scope>
- </dependency>
-
- <dependency>
- <groupId>backport-util-concurrent</groupId>
- <artifactId>backport-util-concurrent</artifactId>
- <version>3.0</version>
- </dependency>
-
- <!-- dependencies for optional code generation functions -->
- <dependency>
- <groupId>asm</groupId>
- <artifactId>asm</artifactId>
- <version>2.2</version>
- <scope>provided</scope>
- <optional>true</optional>
- </dependency>
-
- <!-- dependencies for optional StAX functions -->
- <dependency>
- <groupId>stax</groupId>
- <artifactId>stax-api</artifactId>
- <version>1.0.1</version>
- </dependency>
-
- <dependency>
- <groupId>org.codehaus.woodstox</groupId>
- <artifactId>wstx-asl</artifactId>
- <version>3.2.1</version>
- </dependency>
-
- <!-- dependencies for OSGi support -->
- <dependency>
- <groupId>org.apache.felix</groupId>
- <artifactId>org.apache.felix.main</artifactId>
- <version>1.0.1</version>
- <scope>provided</scope>
- </dependency>
-
- <!-- dependencies for test cases -->
- <dependency>
- <groupId>junit</groupId>
- <artifactId>junit</artifactId>
- <version>4.3.1</version>
- <scope>test</scope>
- </dependency>
-
- </dependencies>
-
- <build>
- <plugins>
- <plugin>
- <artifactId>maven-jar-plugin</artifactId>
- <configuration>
- <archive>
- <manifestEntries>
- <Implementation-Vendor-Id>org.apache</Implementation-Vendor-Id>
- <Implementation-Version>${version}</Implementation-Version>
- <X-Compile-Source-JDK>1.4</X-Compile-Source-JDK>
- <X-Compile-Target-JDK>1.4</X-Compile-Target-JDK>
- </manifestEntries>
- </archive>
- </configuration>
- </plugin>
- <plugin>
- <groupId>org.apache.maven.plugins</groupId>
- <artifactId>maven-jar-plugin</artifactId>
- <version>2.1</version>
- <configuration>
- <archive>
- <manifestEntries>
- <Extension-Name>${project.artifactId}</Extension-Name>
- <Specification-Title>${project.name}</Specification-Title>
- <Specification-Vendor>${project.organization.name}</Specification-Vendor>
- <Specification-Version>${version}</Specification-Version>
- <Implementation-Title>${project.artifactId}</Implementation-Title>
- <Implementation-Vendor>${project.organization.name}</Implementation-Vendor>
- <Implementation-Vendor-Id>org.apache</Implementation-Vendor-Id>
- <Implementation-Version>${project.version}</Implementation-Version>
- <!--
- <Bundle-ManifestVersion>2</Bundle-ManifestVersion>
- <Bundle-Name>${project.name}</Bundle-Name>
- <Bundle-SymbolicName>org.apache.tuscany.sdo.impl</Bundle-SymbolicName>
- <Bundle-Version>1.0.0</Bundle-Version>
- <Bundle-Vendor>${project.organization.name}</Bundle-Vendor>
- -->
- <Require-Bundle>org.eclipse.emf.common,org.eclipse.emf.ecore,org.eclipse.emf.ecore.change,org.eclipse.emf.ecore.xmi,org.eclipse.xsd,org.apache.tuscany.sdo.spec;visibility:=reexport</Require-Bundle>
- <Export-Package>commonj.sdo.impl,org.apache.tuscany.sdo,org.apache.tuscany.sdo.helper,org.apache.tuscany.sdo.impl,org.apache.tuscany.sdo.test,org.apache.tuscany.sdo.util</Export-Package>
- </manifestEntries>
- </archive>
- </configuration>
- </plugin>
- <plugin>
- <groupId>org.apache.maven.plugins</groupId>
- <artifactId>maven-javadoc-plugin</artifactId>
- <version>2.2</version>
- <configuration>
- <overview>${basedir}/src/main/java/org/apache/tuscany/sdo/overview.html</overview>
- <version>2.0</version>
- <source>1.4</source>
- </configuration>
- <!-- <executions>
- <execution>
- <id>package</id>
- <phase>package</phase>
- <goals>
- <goal>jar</goal>
- </goals>
- </execution>
- </executions> -->
- </plugin>
-
- </plugins>
- </build>
-</project>