summaryrefslogtreecommitdiffstats
path: root/cpp/sca/samples/store/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpp/sca/samples/store/Makefile.am')
-rw-r--r--cpp/sca/samples/store/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/cpp/sca/samples/store/Makefile.am b/cpp/sca/samples/store/Makefile.am
new file mode 100644
index 0000000000..0277b96cfe
--- /dev/null
+++ b/cpp/sca/samples/store/Makefile.am
@@ -0,0 +1,41 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+deploydir=$(prefix)/store/deploy
+EXTRA_DIST = *.composite
+deploy_DATA = *.composite
+
+storedir=$(deploydir)
+
+store_PROGRAMS = store-test
+
+store_test_SOURCES = \
+store-test.cpp
+
+store_test_LDADD = \
+-L${TUSCANY_SCACPP}/lib \
+ -ltuscany_sca \
+-L${TUSCANY_SCACPP}/extensions/cpp/lib \
+ -ltuscany_sca_cpp \
+-L${TUSCANY_SDOCPP}/lib \
+ -ltuscany_sdo
+
+INCLUDES = \
+-I$(TUSCANY_SCACPP)/extensions/cpp/include \
+-I${TUSCANY_SCACPP}/include \
+-I${TUSCANY_SDOCPP}/include \
+-I.