summaryrefslogtreecommitdiffstats
path: root/cpp/sca/modules/http/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpp/sca/modules/http/Makefile.am')
-rw-r--r--cpp/sca/modules/http/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/cpp/sca/modules/http/Makefile.am b/cpp/sca/modules/http/Makefile.am
new file mode 100644
index 0000000000..d34da0822f
--- /dev/null
+++ b/cpp/sca/modules/http/Makefile.am
@@ -0,0 +1,32 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+noinst_PROGRAMS = curl-test
+
+libdir=$(prefix)/lib
+lib_LTLIBRARIES = libmod_tuscany.la
+
+INCLUDES = -I. -I$(top_builddir)/kernel -I${HTTPD_INCLUDE} -I${APR_INCLUDE} -I${LIBXML2_INCLUDE} -I${LIBMOZJS_INCLUDE} -I${CURL_INCLUDE}
+
+libmod_tuscany_la_SOURCES = mod.cpp
+libmod_tuscany_la_LIBADD = -lpthread -L${LIBXML2_LIB} -lxml2 -L${LIBMOZJS_LIB} -lmozjs
+
+curl_test_SOURCES = curl-test.cpp
+curl_test_LDADD = -lpthread -L${LIBXML2_LIB} -lxml2 -L${CURL_LIB} -lcurl
+
+TESTS = httpd-test http-test
+