summaryrefslogtreecommitdiffstats
path: root/tags/cpp-stable-20060304/sca/configure.ac
diff options
context:
space:
mode:
authordims <dims@13f79535-47bb-0310-9956-ffa450edef68>2008-06-17 00:23:01 +0000
committerdims <dims@13f79535-47bb-0310-9956-ffa450edef68>2008-06-17 00:23:01 +0000
commitbdd0a41aed7edf21ec2a65cfa17a86af2ef8c48a (patch)
tree38a92061c0793434c4be189f1d70c3458b6bc41d /tags/cpp-stable-20060304/sca/configure.ac
Move Tuscany from Incubator to top level.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@668359 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'tags/cpp-stable-20060304/sca/configure.ac')
-rw-r--r--tags/cpp-stable-20060304/sca/configure.ac51
1 files changed, 51 insertions, 0 deletions
diff --git a/tags/cpp-stable-20060304/sca/configure.ac b/tags/cpp-stable-20060304/sca/configure.ac
new file mode 100644
index 0000000000..9d58b6c824
--- /dev/null
+++ b/tags/cpp-stable-20060304/sca/configure.ac
@@ -0,0 +1,51 @@
+dnl run autogen.sh to generate the configure script.
+
+AC_PREREQ(2.59)
+AC_INIT(tuscany_sca, 1.0.0)
+AC_CANONICAL_SYSTEM
+AM_CONFIG_HEADER(config.h)
+AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
+
+# Checks for programs.
+AC_PROG_CXX
+AC_PROG_CC
+AC_PROG_CPP
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
+AC_PROG_LIBTOOL
+
+# Checks for libraries.
+
+# Checks for header files.
+AC_HEADER_DIRENT
+AC_HEADER_STDC
+AC_CHECK_HEADERS([inttypes.h stdlib.h string.h sys/time.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_STDBOOL
+AC_C_CONST
+AC_C_INLINE
+
+# Checks for library functions.
+AC_FUNC_CLOSEDIR_VOID
+AC_FUNC_STAT
+AC_FUNC_VPRINTF
+AC_CHECK_FUNCS([getcwd putenv strdup])
+
+AC_CONFIG_FILES([Makefile
+ runtime/Makefile
+ runtime/core/Makefile
+ runtime/core/src/Makefile
+ runtime/axis_binding/Makefile
+ runtime/axis_binding/handler/Makefile
+ runtime/axis_binding/handler/src/Makefile
+ runtime/axis_binding/wrapper/Makefile
+ runtime/axis_binding/wrapper/src/Makefile
+ runtime/core/test/Makefile
+ runtime/core/test/CustomerInfo/Makefile
+ runtime/core/test/MyValue/Makefile
+ runtime/core/test/src/Makefile
+ ])
+AC_OUTPUT
+