summaryrefslogtreecommitdiffstats
path: root/tags/cpp-1.0-incubating-M2-final/sca/tools/scagen/Makefile.am
diff options
context:
space:
mode:
authordims <dims@13f79535-47bb-0310-9956-ffa450edef68>2008-06-17 00:23:01 +0000
committerdims <dims@13f79535-47bb-0310-9956-ffa450edef68>2008-06-17 00:23:01 +0000
commitbdd0a41aed7edf21ec2a65cfa17a86af2ef8c48a (patch)
tree38a92061c0793434c4be189f1d70c3458b6bc41d /tags/cpp-1.0-incubating-M2-final/sca/tools/scagen/Makefile.am
Move Tuscany from Incubator to top level.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@668359 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'tags/cpp-1.0-incubating-M2-final/sca/tools/scagen/Makefile.am')
-rw-r--r--tags/cpp-1.0-incubating-M2-final/sca/tools/scagen/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/tags/cpp-1.0-incubating-M2-final/sca/tools/scagen/Makefile.am b/tags/cpp-1.0-incubating-M2-final/sca/tools/scagen/Makefile.am
new file mode 100644
index 0000000000..a9df10fc30
--- /dev/null
+++ b/tags/cpp-1.0-incubating-M2-final/sca/tools/scagen/Makefile.am
@@ -0,0 +1,36 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+SUBDIRS =
+
+BUILT_SOURCES = scagen_build
+EXTRA_DIST = build.xml scagen.sh scagen.cmd src META-INF
+bin_SCRIPTS = scagen.sh scagen.cmd
+
+scagen_build:
+ ant
+ touch scagen_build
+
+clean:
+ rm -f scagen_build
+
+install-exec-hook:
+ cp bld/scagen.jar $(bindir)
+
+
+
+