summaryrefslogtreecommitdiffstats
path: root/tags/cpp-1.0-incubating-M2-RC2/sca/test/configure.ac
diff options
context:
space:
mode:
authordims <dims@13f79535-47bb-0310-9956-ffa450edef68>2008-06-17 00:23:01 +0000
committerdims <dims@13f79535-47bb-0310-9956-ffa450edef68>2008-06-17 00:23:01 +0000
commitbdd0a41aed7edf21ec2a65cfa17a86af2ef8c48a (patch)
tree38a92061c0793434c4be189f1d70c3458b6bc41d /tags/cpp-1.0-incubating-M2-RC2/sca/test/configure.ac
Move Tuscany from Incubator to top level.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@668359 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'tags/cpp-1.0-incubating-M2-RC2/sca/test/configure.ac')
-rw-r--r--tags/cpp-1.0-incubating-M2-RC2/sca/test/configure.ac34
1 files changed, 34 insertions, 0 deletions
diff --git a/tags/cpp-1.0-incubating-M2-RC2/sca/test/configure.ac b/tags/cpp-1.0-incubating-M2-RC2/sca/test/configure.ac
new file mode 100644
index 0000000000..f84c32ab1e
--- /dev/null
+++ b/tags/cpp-1.0-incubating-M2-RC2/sca/test/configure.ac
@@ -0,0 +1,34 @@
+dnl run autogen.sh to generate the configure script.
+
+AC_PREREQ(2.59)
+AC_INIT(tuscany_sca_tests, 0.1.incubating-M1)
+AC_CANONICAL_SYSTEM
+AM_CONFIG_HEADER(config.h)
+AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
+AC_PREFIX_DEFAULT(/usr/local/tuscany/sca/test)
+
+# Checks for programs.
+AC_PROG_CXX
+AC_PROG_CC
+AC_PROG_CPP
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
+AC_PROG_LIBTOOL
+
+# Check for dynamic library suffixes
+AC_MSG_CHECKING([checking for dynamic library suffix])
+AC_CHECK_HEADER([sys/appleapiopts.h],
+ [AC_SUBST([libsuffix],[".dylib"]) AC_MSG_RESULT([using .dylib])],
+ [AC_SUBST([libsuffix],[".so"]) AC_MSG_RESULT([using .so])]
+)
+
+
+AC_CONFIG_FILES([Makefile
+ ws.service.interop/Makefile
+ ws.service.interop/resources/Makefile
+ ws.service.interop/ws.service.interop/Makefile
+ ws.service.interop/ws.service.interop.client/Makefile
+ ])
+AC_OUTPUT
+