summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/samples/store-gae/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-07-01 06:04:35 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-07-01 06:04:35 +0000
commitac8bb2ddecac09d60760ef83319b627548d0fd77 (patch)
treeb15d73262f02989d8dfe554e127e82e70b5aebe4 /sca-cpp/trunk/samples/store-gae/Makefile.am
parent54561e00c9714c9230dc1ed39f3bb548a59adeed (diff)
Minimal support for implementation.widget, using simplified (and generic) JSONRPC and ATOMPub Javascript proxies. Minor changes to the server runtime to serve reference requests from widgets. Adjust and simplified samples using the widget support.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@959521 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/samples/store-gae/Makefile.am')
-rw-r--r--sca-cpp/trunk/samples/store-gae/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/sca-cpp/trunk/samples/store-gae/Makefile.am b/sca-cpp/trunk/samples/store-gae/Makefile.am
index 2ca00bb505..59a8b82ce7 100644
--- a/sca-cpp/trunk/samples/store-gae/Makefile.am
+++ b/sca-cpp/trunk/samples/store-gae/Makefile.am
@@ -22,18 +22,21 @@ dist_sample_SCRIPTS = start stop
sampledir = $(prefix)/samples/store-gae
BUILT_SOURCES = target.stamp
-target.stamp: app.yaml *.py *.composite $(top_builddir)/modules/wsgi/*.py htdocs/*
+target.stamp: app.yaml *.py *.composite $(top_builddir)/modules/wsgi/*.py htdocs/* $(top_builddir)/modules/server/htdocs/js/*
mkdir -p target
cp app.yaml *.py *.composite `ls $(top_builddir)/modules/wsgi/*.py | grep -v "\-test"` target
- cp -R htdocs target/htdocs
+ mkdir -p target/htdocs
+ cp -R htdocs/* target/htdocs
+ mkdir target/htdocs/js
+ cp -R $(top_builddir)/modules/server/htdocs/js/* target/htdocs/js
touch target.stamp
clean-local:
rm -rf target.stamp target
-nobase_sample_DATA = target/app.yaml target/*.py target/*.composite target/htdocs/*.html target/htdocs/*.js
+nobase_sample_DATA = target/app.yaml target/*.py target/*.composite target/htdocs/*.html target/htdocs/js/*.js
-EXTRA_DIST = app.yaml *.composite *.py htdocs/*.html htdocs/*.js
+EXTRA_DIST = app.yaml *.composite *.py htdocs/*.html
dist_noinst_SCRIPTS = server-test
TESTS = server-test