summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/modules/python/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-05-30 03:32:37 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-05-30 03:32:37 +0000
commit90b55b93704adb3e1fac59d58c2d644d37537bc9 (patch)
treec35f9d4d69789ab45343439044daf9849d1eb4ff /sca-cpp/trunk/modules/python/Makefile.am
parent3cdc93215b4b0be782060438eec8c20b9c5152ce (diff)
Fix source distribution build scripts, add missing files to the dist targets.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@949466 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/modules/python/Makefile.am')
-rw-r--r--sca-cpp/trunk/modules/python/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/sca-cpp/trunk/modules/python/Makefile.am b/sca-cpp/trunk/modules/python/Makefile.am
index 0e49cdfaad..62998b2bd8 100644
--- a/sca-cpp/trunk/modules/python/Makefile.am
+++ b/sca-cpp/trunk/modules/python/Makefile.am
@@ -21,10 +21,10 @@ if WANT_PYTHON
INCLUDES = -I${PYTHON_INCLUDE}
-mod_SCRIPTS = python-conf
+dist_mod_SCRIPTS = python-conf
moddir = $(prefix)/modules/python
-nobase_xsd_DATA = *.xsd
+nobase_dist_xsd_DATA = *.xsd
xsddir = $(prefix)/xsd
prefix_DATA = python.prefix
@@ -32,6 +32,8 @@ prefixdir = $(prefix)/modules/python
python.prefix: $(top_builddir)/config.status
echo ${PYTHON_PREFIX} >python.prefix
+EXTRA_DIST = domain-test.composite client-test.py server-test.py
+
lib_LTLIBRARIES = libmod_tuscany_python.la
libmod_tuscany_python_la_SOURCES = mod-python.cpp
libmod_tuscany_python_la_LDFLAGS = -lxml2 -lcurl -lmozjs -L${PYTHON_LIB} -R${PYTHON_LIB} -lpython2.6
@@ -48,6 +50,7 @@ python_shell_LDFLAGS = -L${PYTHON_LIB} -R${PYTHON_LIB} -lpython2.6
client_test_SOURCES = client-test.cpp
client_test_LDFLAGS = -lxml2 -lcurl -lmozjs
+dist_noinst_SCRIPTS = server-test wiring-test
noinst_PROGRAMS = python-test python-shell client-test
TESTS = python-test server-test