summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/modules/python/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-06-05 05:38:55 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-06-05 05:38:55 +0000
commit70520addf9ca828a9e1c08652999902bdc8d1809 (patch)
treeac364cba9028a1c121a6edfaa23fea76d812e6f3 /sca-cpp/trunk/modules/python/Makefile.am
parent69c6e0618ad4f18d18771ef91aacbb5c5a68f3a2 (diff)
Add build support for a minimum distribution using prebuilt dependencies from Ubuntu 9.10.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@951656 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/modules/python/Makefile.am')
-rw-r--r--sca-cpp/trunk/modules/python/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/sca-cpp/trunk/modules/python/Makefile.am b/sca-cpp/trunk/modules/python/Makefile.am
index f8b200d96a..2f56b9a1db 100644
--- a/sca-cpp/trunk/modules/python/Makefile.am
+++ b/sca-cpp/trunk/modules/python/Makefile.am
@@ -15,12 +15,14 @@
# specific language governing permissions and limitations
# under the License.
-libdir = $(prefix)/modules/python
if WANT_PYTHON
INCLUDES = -I${PYTHON_INCLUDE}
+incl_HEADERS = *.hpp
+incldir = $(prefix)/include/modules/python
+
dist_mod_SCRIPTS = python-conf
moddir = $(prefix)/modules/python
@@ -31,7 +33,7 @@ python.prefix: $(top_builddir)/config.status
EXTRA_DIST = domain-test.composite client-test.py server-test.py
-lib_LTLIBRARIES = libmod_tuscany_python.la
+mod_LTLIBRARIES = libmod_tuscany_python.la
libmod_tuscany_python_la_SOURCES = mod-python.cpp
libmod_tuscany_python_la_LDFLAGS = -lxml2 -lcurl -lmozjs -L${PYTHON_LIB} -R${PYTHON_LIB} -lpython2.6
noinst_DATA = libmod_tuscany_python.so