summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/modules/java/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-01-11 08:29:39 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-01-11 08:29:39 +0000
commit81678737cc3682dd811660ca794851b72e2b1fbe (patch)
tree62d0ffd191130ed443c777fdad7a24eea157b157 /sca-cpp/trunk/modules/java/Makefile.am
parentf5202e9e875e5e6c797e97c4db53f1f4d7364c65 (diff)
Added utility functions to help call Java code using JNI and wrap Axis2/java in a component.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@897789 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/modules/java/Makefile.am')
-rw-r--r--sca-cpp/trunk/modules/java/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/sca-cpp/trunk/modules/java/Makefile.am b/sca-cpp/trunk/modules/java/Makefile.am
new file mode 100644
index 0000000000..790277104b
--- /dev/null
+++ b/sca-cpp/trunk/modules/java/Makefile.am
@@ -0,0 +1,39 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+datadir=$(prefix)/modules/java
+JAVAROOT = $(top_builddir)/modules/java
+
+if WANT_JAVA
+
+noinst_PROGRAMS = java-test java-shell
+
+INCLUDES = -I${JAVA_INCLUDE}
+
+java_test_SOURCES = java-test.cpp
+java_test_LDADD = -L${JAVA_LIB} -ljava
+java_test_LDFLAGS = -rpath ${JAVA_LIB} -rpath ${JAVA_LIB}/server
+
+java_shell_SOURCES = java-shell.cpp
+java_shell_LDADD = -L${JAVA_LIB} -ljava
+java_shell_LDFLAGS = -rpath ${JAVA_LIB} -rpath ${JAVA_LIB}/server
+
+noinst_JAVA = org/apache/tuscany/*.java test/*.java
+
+TESTS = java-test
+
+endif \ No newline at end of file