summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/components/webservice/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-03-01 09:59:18 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-03-01 09:59:18 +0000
commit99af35834fb7655f090af2a3ec01d09d3aa3f69c (patch)
treecee868b609e1e43ec9f2cab9b56bb36388b98ced /sca-cpp/trunk/components/webservice/Makefile.am
parentedc5e5d1f4d00bb499606e92bada758e821dca15 (diff)
Minor fixes to distro build. Added missing scripts. Placed libraries in the correct module and component directories.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@917438 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/components/webservice/Makefile.am')
-rw-r--r--sca-cpp/trunk/components/webservice/Makefile.am11
1 files changed, 5 insertions, 6 deletions
diff --git a/sca-cpp/trunk/components/webservice/Makefile.am b/sca-cpp/trunk/components/webservice/Makefile.am
index 264b150c93..3f0ef3373e 100644
--- a/sca-cpp/trunk/components/webservice/Makefile.am
+++ b/sca-cpp/trunk/components/webservice/Makefile.am
@@ -17,13 +17,14 @@
if WANT_WEBSERVICE
-noinst_PROGRAMS = axiom-test axis2-test client-test
-
INCLUDES = -I${AXIS2C_INCLUDE}
+comp_DATA = axis2c.prefix
compdir=$(prefix)/components/webservice
+axis2c.prefix: $(top_builddir)/config.status
+ echo ${AXIS2C_PREFIX} >axis2c.prefix
+
comp_LTLIBRARIES = libwebservice-client.la libwebservice-listener.la libaxis2-dispatcher.la libaxis2-service.la
-comp_DATA = axis2c.prefix
libwebservice_client_la_SOURCES = webservice-client.cpp
libwebservice_client_la_LDFLAGS = -lxml2 -L${AXIS2C_LIB} -R${AXIS2C_LIB} -laxis2_engine
@@ -46,9 +47,7 @@ axis2_test_LDFLAGS = -lxml2 -L${AXIS2C_LIB} -R${AXIS2C_LIB} -laxis2_engine
client_test_SOURCES = client-test.cpp
client_test_LDFLAGS = -lxml2 -lcurl -lmozjs -L${AXIS2C_LIB} -R${AXIS2C_LIB} -laxis2_engine
-axis2c.prefix: $(top_builddir)/config.status
- echo ${AXIS2C_PREFIX} >axis2c.prefix
-
+noinst_PROGRAMS = axiom-test axis2-test client-test
TESTS = axiom-test echo-test server-test
endif