summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/components/webservice/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-01-11 08:29:45 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-01-11 08:29:45 +0000
commit030239cff2f98c0e7b2a66e1930008eed418e07d (patch)
tree6c5082ff8ccd673487404d4e20df1c1d26fd2ee4 /sca-cpp/trunk/components/webservice/Makefile.am
parent81678737cc3682dd811660ca794851b72e2b1fbe (diff)
Created component structure and build files for Web service component using Axis2/C.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@897790 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/components/webservice/Makefile.am')
-rw-r--r--sca-cpp/trunk/components/webservice/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/sca-cpp/trunk/components/webservice/Makefile.am b/sca-cpp/trunk/components/webservice/Makefile.am
new file mode 100644
index 0000000000..e2971b5182
--- /dev/null
+++ b/sca-cpp/trunk/components/webservice/Makefile.am
@@ -0,0 +1,38 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+if WANT_WEBSERVICE
+
+noinst_PROGRAMS = webservice-test client-test
+
+INCLUDES = -I${AXIS2C_INCLUDE}
+
+compdir=$(prefix)/components/webservice
+comp_LTLIBRARIES = libwebservice.la
+
+libwebservice_la_SOURCES = webservice.cpp
+libwebservice_la_LIBADD = -lxml2 -L${AXIS2C_LIB} -laxis2_engine
+
+webservice_test_SOURCES = webservice-test.cpp
+webservice_test_LDADD = -lxml2 -L${AXIS2C_LIB} -laxis2_engine
+
+client_test_SOURCES = client-test.cpp
+client_test_LDADD = -lxml2 -lcurl -lmozjs
+
+TESTS = webservice-test client-test
+
+endif \ No newline at end of file