summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/components/nosqldb/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-04-17 22:59:51 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-04-17 22:59:51 +0000
commitcd904cdd0a82ad3c7859b5bc4365202c320da81f (patch)
tree45fbd4e5fdb92cdd327dab1775d29ae7d3dc1d5a /sca-cpp/trunk/components/nosqldb/Makefile.am
parent3d79be04a42d86838a110d679de4004d5b98b789 (diff)
Strawman implementation of post, put and delete on a tinycdb database, for now just a simplistic rewrite of the db per update.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@935274 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/components/nosqldb/Makefile.am')
-rw-r--r--sca-cpp/trunk/components/nosqldb/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/sca-cpp/trunk/components/nosqldb/Makefile.am b/sca-cpp/trunk/components/nosqldb/Makefile.am
new file mode 100644
index 0000000000..6a9b0bdfdd
--- /dev/null
+++ b/sca-cpp/trunk/components/nosqldb/Makefile.am
@@ -0,0 +1,42 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+if WANT_NOSQLDB
+
+INCLUDES = -I${TINYCDB_INCLUDE}
+
+compdir=$(prefix)/components/nosqldb
+
+comp_DATA = tinycdb.prefix
+tinycdb.prefix: $(top_builddir)/config.status
+ echo ${TINYCDB_PREFIX} >tinycdb.prefix
+
+#comp_LTLIBRARIES = libnosqldb.la
+
+#libnosqldb_la_SOURCES = nosqldb.cpp
+#libnosqldb_la_LDFLAGS = -L${TINYCDB_LIB} -R${TINYCDB_LIB} -lcdb
+
+tinycdb_test_SOURCES = tinycdb-test.cpp
+tinycdb_test_LDFLAGS = -L${TINYCDB_LIB} -R${TINYCDB_LIB} -lcdb
+
+client_test_SOURCES = client-test.cpp
+client_test_LDFLAGS = -lxml2 -lcurl -lmozjs
+
+noinst_PROGRAMS = tinycdb-test client-test
+TESTS = nosqldb-test
+
+endif