summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/components/http/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2011-04-17 22:14:29 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2011-04-17 22:14:29 +0000
commit84dfee258c65ba901a01da176f07eef1f61294bd (patch)
tree7740eb6391c7a5c47172ab37d3c741f197888668 /sca-cpp/trunk/components/http/Makefile.am
parentd198f74e5f833d358625c22b708c003646f1bdb7 (diff)
Add an XMPP message sender component that only connects to an XMPP server as needed just before sending a message to avoid unnecessary connects / disconnects in a dynamic virtual host environment. Add another component that does an HTTP delete.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@1094212 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/components/http/Makefile.am')
-rw-r--r--sca-cpp/trunk/components/http/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/sca-cpp/trunk/components/http/Makefile.am b/sca-cpp/trunk/components/http/Makefile.am
index 05e41bb9e1..4388ec8057 100644
--- a/sca-cpp/trunk/components/http/Makefile.am
+++ b/sca-cpp/trunk/components/http/Makefile.am
@@ -17,16 +17,21 @@
compdir=$(prefix)/components/http
-EXTRA_DIST = http.composite httpget.componentType *.scm
+EXTRA_DIST = http.composite httpget.componentType httpdelete.componentType *.scm
-comp_LTLIBRARIES = libhttpget.la
-noinst_DATA = libhttpget.so
+comp_LTLIBRARIES = libhttpget.la libhttpdelete.la
+noinst_DATA = libhttpget.so libhttpdelete.so
libhttpget_la_SOURCES = httpget.cpp
libhttpget_la_LDFLAGS = -lxml2 -lmozjs -curl
libhttpget.so:
ln -s .libs/libhttpget.so
+libhttpdelete_la_SOURCES = httpdelete.cpp
+libhttpdelete_la_LDFLAGS = -lxml2 -lmozjs -curl
+libhttpdelete.so:
+ ln -s .libs/libhttpdelete.so
+
client_test_SOURCES = client-test.cpp
client_test_LDFLAGS = -lxml2 -lcurl -lmozjs