summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/components/chat/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-03-01 09:59:18 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-03-01 09:59:18 +0000
commit99af35834fb7655f090af2a3ec01d09d3aa3f69c (patch)
treecee868b609e1e43ec9f2cab9b56bb36388b98ced /sca-cpp/trunk/components/chat/Makefile.am
parentedc5e5d1f4d00bb499606e92bada758e821dca15 (diff)
Minor fixes to distro build. Added missing scripts. Placed libraries in the correct module and component directories.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@917438 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/components/chat/Makefile.am')
-rw-r--r--sca-cpp/trunk/components/chat/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/sca-cpp/trunk/components/chat/Makefile.am b/sca-cpp/trunk/components/chat/Makefile.am
index 11e3179e8a..944484946e 100644
--- a/sca-cpp/trunk/components/chat/Makefile.am
+++ b/sca-cpp/trunk/components/chat/Makefile.am
@@ -17,13 +17,10 @@
if WANT_CHAT
-noinst_PROGRAMS = xmpp-test client-test
-
INCLUDES = -I${LIBSTROPHE_INCLUDE} -I${LIBSTROPHE_INCLUDE}/src
-compdir=$(prefix)/components/chat
comp_LTLIBRARIES = libchatter.la
-
+compdir=$(prefix)/components/chat
libchatter_la_SOURCES = chatter.cpp
libchatter_la_LDFLAGS = -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lexpat -lssl -lresolv
@@ -33,4 +30,6 @@ xmpp_test_LDFLAGS = -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lexpat -l
client_test_SOURCES = client-test.cpp
client_test_LDFLAGS = -lxml2 -lcurl -lmozjs -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lexpat -lssl -lresolv
+noinst_PROGRAMS = xmpp-test client-test
+
endif