summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/components/chat/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-05-30 03:32:37 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-05-30 03:32:37 +0000
commit90b55b93704adb3e1fac59d58c2d644d37537bc9 (patch)
treec35f9d4d69789ab45343439044daf9849d1eb4ff /sca-cpp/trunk/components/chat/Makefile.am
parent3cdc93215b4b0be782060438eec8c20b9c5152ce (diff)
Fix source distribution build scripts, add missing files to the dist targets.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@949466 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/components/chat/Makefile.am')
-rw-r--r--sca-cpp/trunk/components/chat/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/sca-cpp/trunk/components/chat/Makefile.am b/sca-cpp/trunk/components/chat/Makefile.am
index e7093caa2e..c82e94c371 100644
--- a/sca-cpp/trunk/components/chat/Makefile.am
+++ b/sca-cpp/trunk/components/chat/Makefile.am
@@ -21,13 +21,15 @@ if WANT_CHAT
INCLUDES = -I${LIBSTROPHE_INCLUDE}
-comp_SCRIPTS = vysper-start vysper-stop vysper-classpath
+dist_comp_SCRIPTS = vysper-start vysper-stop vysper-classpath
compdir=$(prefix)/components/chat
comp_DATA = vysper.prefix
vysper.prefix: $(top_builddir)/config.status
echo ${VYSPER_PREFIX} >vysper.prefix
+EXTRA_DIST = chat.composite *.scm
+
comp_LTLIBRARIES = libchatter.la
libchatter_la_SOURCES = chatter.cpp
libchatter_la_LDFLAGS = -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lexpat -lssl -lresolv
@@ -42,13 +44,15 @@ client_test_SOURCES = client-test.cpp
client_test_LDFLAGS = -lxml2 -lcurl -lmozjs -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lexpat -lssl -lresolv
noinst_PROGRAMS = xmpp-test client-test
+dist_noinst_SCRIPTS = server-test
if WANT_VYSPER
AM_JAVACFLAGS = -cp `${top_builddir}/components/chat/vysper-classpath ${VYSPER_PREFIX}`${JAVAROOT}
-noinst_JAVA = test/*.java
+dist_noinst_JAVA = test/*.java
CLEANFILES = test/*.class
+dist_noinst_SCRIPTS += echo-test
TESTS = echo-test
endif