summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/components/chat/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2011-04-17 22:14:29 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2011-04-17 22:14:29 +0000
commit84dfee258c65ba901a01da176f07eef1f61294bd (patch)
tree7740eb6391c7a5c47172ab37d3c741f197888668 /sca-cpp/trunk/components/chat/Makefile.am
parentd198f74e5f833d358625c22b708c003646f1bdb7 (diff)
Add an XMPP message sender component that only connects to an XMPP server as needed just before sending a message to avoid unnecessary connects / disconnects in a dynamic virtual host environment. Add another component that does an HTTP delete.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@1094212 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/components/chat/Makefile.am')
-rw-r--r--sca-cpp/trunk/components/chat/Makefile.am18
1 files changed, 14 insertions, 4 deletions
diff --git a/sca-cpp/trunk/components/chat/Makefile.am b/sca-cpp/trunk/components/chat/Makefile.am
index 35fb57daf3..8856e536fd 100644
--- a/sca-cpp/trunk/components/chat/Makefile.am
+++ b/sca-cpp/trunk/components/chat/Makefile.am
@@ -31,10 +31,10 @@ comp_DATA = vysper.prefix
vysper.prefix: $(top_builddir)/config.status
echo ${VYSPER_PREFIX} >vysper.prefix
-EXTRA_DIST = chat.composite chat-sendreceiver.componentType chat-sender.componentType *.scm
+EXTRA_DIST = chat.composite chat-sendreceiver.componentType chat-sender.componentType chat-sender2.componentType *.scm
-comp_LTLIBRARIES = libchat-sendreceiver.la libchat-sender.la
-noinst_DATA = libchat-sendreceiver.so libchat-sender.so
+comp_LTLIBRARIES = libchat-sendreceiver.la libchat-sender.la libchat-sender2.la
+noinst_DATA = libchat-sendreceiver.so libchat-sender.so libchat-sender2.so
libchat_sendreceiver_la_SOURCES = chat-sendreceiver.cpp
libchat_sendreceiver_la_LDFLAGS = -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lssl -lresolv
@@ -46,12 +46,22 @@ libchat_sender_la_LDFLAGS = -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -l
libchat-sender.so:
ln -s .libs/libchat-sender.so
+libchat_sender2_la_SOURCES = chat-sender2.cpp
+libchat_sender2_la_LDFLAGS = -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lssl -lresolv
+libchat-sender2.so:
+ ln -s .libs/libchat-sender2.so
+
+chat_send_SOURCES = chat-send.cpp
+chat_send_LDFLAGS = -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lssl -lresolv
+
xmpp_test_SOURCES = xmpp-test.cpp
xmpp_test_LDFLAGS = -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lssl -lresolv
client_test_SOURCES = client-test.cpp
client_test_LDFLAGS = -lxml2 -lcurl -lmozjs -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lssl -lresolv
+comp_PROGRAMS = chat-send
+
noinst_PROGRAMS = xmpp-test client-test
dist_noinst_SCRIPTS = server-test
@@ -62,7 +72,7 @@ dist_noinst_JAVA = test/*.java
CLEANFILES = test/*.class
dist_noinst_SCRIPTS += echo-test
-TESTS = echo-test
+TESTS = echo-test server-test
endif
endif