summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/components/chat/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-02-01 07:57:32 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-02-01 07:57:32 +0000
commit80f6823cacf6f018cbe0d86198afa23be71f991f (patch)
tree64181f34f79e158e945c8e3aba7da2d3514f0bc7 /sca-cpp/trunk/components/chat/Makefile.am
parent8c5172b8ab407b79db53ce46271d72d8a3f9c19f (diff)
Added build configuration and dependencies for chat and queue components.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@905203 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/components/chat/Makefile.am')
-rw-r--r--sca-cpp/trunk/components/chat/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/sca-cpp/trunk/components/chat/Makefile.am b/sca-cpp/trunk/components/chat/Makefile.am
index 09cb5fa26a..ea63a475e2 100644
--- a/sca-cpp/trunk/components/chat/Makefile.am
+++ b/sca-cpp/trunk/components/chat/Makefile.am
@@ -15,6 +15,17 @@
# specific language governing permissions and limitations
# under the License.
-if WANT_STORE
+if WANT_CHAT
+
+INCLUDES = -I${LIBSTROPHE_INCLUDE}
+
+compdir=$(prefix)/components/chat
+comp_LTLIBRARIES = libchat-sender.la libchat-listener.la
+
+libchat_sender_la_SOURCES = chat-sender.cpp
+libchat_sender_la_LDFLAGS = -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lexpat -lssl -lresolv
+
+libchat_listener_la_SOURCES = chat-listener.cpp
+libchat_listener_la_LDFLAGS = -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lexpat -lssl -lresolv
endif