summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/components/chat/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-05-31 17:42:16 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-05-31 17:42:16 +0000
commit76cf55f98aad01d77a19330855b1b7712ad7a031 (patch)
tree20f8300221b496764ad2452436d17f12435d0e29 /sca-cpp/trunk/components/chat/Makefile.am
parentb85f56b7c32f101ad41255bde647bbdcd12dd796 (diff)
Build the expat XML parser separately instead of building it as part of libstrophe.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@949816 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/components/chat/Makefile.am')
-rw-r--r--sca-cpp/trunk/components/chat/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/sca-cpp/trunk/components/chat/Makefile.am b/sca-cpp/trunk/components/chat/Makefile.am
index c82e94c371..5e48f74065 100644
--- a/sca-cpp/trunk/components/chat/Makefile.am
+++ b/sca-cpp/trunk/components/chat/Makefile.am
@@ -32,16 +32,16 @@ EXTRA_DIST = chat.composite *.scm
comp_LTLIBRARIES = libchatter.la
libchatter_la_SOURCES = chatter.cpp
-libchatter_la_LDFLAGS = -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lexpat -lssl -lresolv
+libchatter_la_LDFLAGS = -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lssl -lresolv
noinst_DATA = libchatter.so
libchatter.so:
ln -s .libs/libchatter.so
xmpp_test_SOURCES = xmpp-test.cpp
-xmpp_test_LDFLAGS = -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lexpat -lssl -lresolv
+xmpp_test_LDFLAGS = -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lssl -lresolv
client_test_SOURCES = client-test.cpp
-client_test_LDFLAGS = -lxml2 -lcurl -lmozjs -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lexpat -lssl -lresolv
+client_test_LDFLAGS = -lxml2 -lcurl -lmozjs -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lssl -lresolv
noinst_PROGRAMS = xmpp-test client-test
dist_noinst_SCRIPTS = server-test