summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/components/chat/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-03-10 09:34:11 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-03-10 09:34:11 +0000
commit39a1a1829a496c6f0bfdb3439e9958b8734461c4 (patch)
treeb3c81437e78b854bd94a057760765442eec59e57 /sca-cpp/trunk/components/chat/Makefile.am
parent336e959047784f9a95e7a8070a542b343b9197e2 (diff)
Added an XMPP test server using Apache Vysper, to help test the XMPP Chat component.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@921269 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/components/chat/Makefile.am')
-rw-r--r--sca-cpp/trunk/components/chat/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/sca-cpp/trunk/components/chat/Makefile.am b/sca-cpp/trunk/components/chat/Makefile.am
index 944484946e..9ab64c388c 100644
--- a/sca-cpp/trunk/components/chat/Makefile.am
+++ b/sca-cpp/trunk/components/chat/Makefile.am
@@ -15,12 +15,20 @@
# specific language governing permissions and limitations
# under the License.
+JAVAROOT = $(top_builddir)/components/chat
+
if WANT_CHAT
INCLUDES = -I${LIBSTROPHE_INCLUDE} -I${LIBSTROPHE_INCLUDE}/src
-comp_LTLIBRARIES = libchatter.la
+comp_SCRIPTS = vysper-start vysper-stop vysper-classpath
compdir=$(prefix)/components/chat
+
+comp_DATA = vysper.prefix
+vysper.prefix: $(top_builddir)/config.status
+ echo ${VYSPER_PREFIX} >vysper.prefix
+
+comp_LTLIBRARIES = libchatter.la
libchatter_la_SOURCES = chatter.cpp
libchatter_la_LDFLAGS = -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lexpat -lssl -lresolv
@@ -32,4 +40,13 @@ client_test_LDFLAGS = -lxml2 -lcurl -lmozjs -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_L
noinst_PROGRAMS = xmpp-test client-test
+if WANT_VYSPER
+
+AM_JAVACFLAGS = -cp `${top_builddir}/components/chat/vysper-classpath`${JAVAROOT}
+
+noinst_JAVA = test/*.java
+
+CLEANFILES = test/*.class
+endif
+
endif