summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2009-11-23 05:48:11 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2009-11-23 05:48:11 +0000
commit1c2df9a2458897ff6c2393913b2723457e42a0da (patch)
tree69652a0305830b4472f39c55ad1168522d8301f1 /sca-cpp/trunk/Makefile.am
parente5d978186780787e8dad6681cca139486df93643 (diff)
Simplified the automake build using configure options instead of environment variables and cleaned up some of the makefile.am files. Adjusted build instructions. Moved directories that don't yet build or work out of the main build dir and obsolete docs to a contrib dir.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@883254 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/Makefile.am')
-rw-r--r--sca-cpp/trunk/Makefile.am32
1 files changed, 15 insertions, 17 deletions
diff --git a/sca-cpp/trunk/Makefile.am b/sca-cpp/trunk/Makefile.am
index caa00d389a..df348fbc3c 100644
--- a/sca-cpp/trunk/Makefile.am
+++ b/sca-cpp/trunk/Makefile.am
@@ -15,16 +15,16 @@
# specific language governing permissions and limitations
# under the License.
-SUBDIRS = kernel modules test doc runtime
-DIST_SUBDIRS = doc runtime samples
+ACLOCAL_AMFLAGS = -I m4
+
+SUBDIRS = kernel modules components test doc
+
datadir=$(prefix)
-data_DATA = INSTALL README LICENSE COPYING NOTICE GettingStarted.html
+data_DATA = INSTALL README LICENSE COPYING NOTICE
nobase_data_DATA = xsd/*.*
-EXTRA_DIST = LICENSE COPYING INSTALL README NOTICE autogen.sh build.sh builddist.sh configure.sh makebindist.sh GettingStarted.html xsd
-dist-hook:
- rm -rf `find $(distdir)/ -type d -name .svn`
- rm -rf `find $(distdir)/ -type d -name .deps`
+DIST_SUBDIRS = kernel modules components test doc samples
+EXTRA_DIST = LICENSE COPYING INSTALL README NOTICE autogen.sh xsd
install-data-hook:
rm -rf $(prefix)/doc
@@ -38,17 +38,15 @@ install-data-hook:
rm -rf `find $(prefix)/samples -type d -name .svn`
rm -rf `find $(prefix)/samples -type d -name .deps`
-bindist: dist
- rm -rf ${PACKAGE}-${PACKAGE_VERSION}
- rm -rf ${PACKAGE}-${PACKAGE_VERSION}-src
+dist-hook:
+ rm -rf `find $(distdir)/ -type d -name .svn`
+ rm -rf `find $(distdir)/ -type d -name .deps`
+
+bindist: install
rm -rf ${PACKAGE}-${PACKAGE_VERSION}-bin
- gunzip -f ${PACKAGE}-${PACKAGE_VERSION}.tar.gz
- tar -xf ${PACKAGE}-${PACKAGE_VERSION}.tar
- mv ${PACKAGE}-${PACKAGE_VERSION} ${PACKAGE}-${PACKAGE_VERSION}-src
- tar -cf - ${PACKAGE}-${PACKAGE_VERSION}-src | gzip -c > ${PACKAGE}-${PACKAGE_VERSION}-src.tar.gz
- cd ${PACKAGE}-${PACKAGE_VERSION}-src \
- && sh ../makebindist.sh
mkdir ${PACKAGE}-${PACKAGE_VERSION}-bin
- cp -r ${PACKAGE}-${PACKAGE_VERSION}-src/deploy/* ${PACKAGE}-${PACKAGE_VERSION}-bin
+ cp -r $(prefix)/* ${PACKAGE}-${PACKAGE_VERSION}-bin
+ rm -rf ${PACKAGE}-${PACKAGE_VERSION}-bin/test
tar -cf - ${PACKAGE}-${PACKAGE_VERSION}-bin | gzip -c > ${PACKAGE}-${PACKAGE_VERSION}-bin.tar.gz
+ rm -rf ${PACKAGE}-${PACKAGE_VERSION}-bin