summaryrefslogtreecommitdiffstats
path: root/sca-cpp/branches/gcc-4.4/modules/http/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-04-17 05:00:18 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-04-17 05:00:18 +0000
commit5e5a4c9daa1bc9da5ee0d6121e51e067d9017037 (patch)
tree97836c5a49ffee90f8f707cab8efbf55c0c45cd3 /sca-cpp/branches/gcc-4.4/modules/http/Makefile.am
parent45629fcf8a2f5d6048868e16292d28fe73808ebd (diff)
Copy trunk into gcc-4.4 branch before porting to gcc-4.5.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@935127 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/branches/gcc-4.4/modules/http/Makefile.am')
-rw-r--r--sca-cpp/branches/gcc-4.4/modules/http/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/sca-cpp/branches/gcc-4.4/modules/http/Makefile.am b/sca-cpp/branches/gcc-4.4/modules/http/Makefile.am
new file mode 100644
index 0000000000..180529620c
--- /dev/null
+++ b/sca-cpp/branches/gcc-4.4/modules/http/Makefile.am
@@ -0,0 +1,34 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+INCLUDES = -I${HTTPD_INCLUDE}
+
+moddir=$(prefix)/modules/http
+mod_SCRIPTS = httpd-conf httpd-start httpd-stop httpd-restart
+
+curl_test_SOURCES = curl-test.cpp
+curl_test_LDFLAGS = -lxml2 -lcurl -lmozjs
+
+prefix_DATA = httpd.prefix curl.prefix
+prefixdir=$(prefix)/modules/http
+httpd.prefix: $(top_builddir)/config.status
+ echo ${HTTPD_PREFIX} >httpd.prefix
+curl.prefix: $(top_builddir)/config.status
+ echo ${CURL_PREFIX} >curl.prefix
+
+noinst_PROGRAMS = curl-test
+TESTS = httpd-test http-test