summaryrefslogtreecommitdiffstats
path: root/sca-cpp/branches/cpp-M1/sca/runtime/ws_service/axis2c/src/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2009-11-16 06:23:13 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2009-11-16 06:23:13 +0000
commit8759a126a1bb9eec550c37b5b14642b0cfeb797b (patch)
treebc4744f903d38710e61a9e8ca6766132e5926201 /sca-cpp/branches/cpp-M1/sca/runtime/ws_service/axis2c/src/Makefile.am
parentfd1aa20dd751f242e2df5ee61c84dfbd7c0ebb83 (diff)
Cleaning up SVN structure, moving branch under sca-cpp/branches.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@880612 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/branches/cpp-M1/sca/runtime/ws_service/axis2c/src/Makefile.am')
-rw-r--r--sca-cpp/branches/cpp-M1/sca/runtime/ws_service/axis2c/src/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/sca-cpp/branches/cpp-M1/sca/runtime/ws_service/axis2c/src/Makefile.am b/sca-cpp/branches/cpp-M1/sca/runtime/ws_service/axis2c/src/Makefile.am
new file mode 100644
index 0000000000..22bf2f2276
--- /dev/null
+++ b/sca-cpp/branches/cpp-M1/sca/runtime/ws_service/axis2c/src/Makefile.am
@@ -0,0 +1,27 @@
+lib_LTLIBRARIES = libtuscany_sca_ws_service.la
+
+libtuscany_sca_ws_service_la_SOURCES = Axis2EntryPointService_skeleton.cpp Axis2Utils.cpp
+
+noinst_HEADERS = *.h
+
+AM_CPPFLAGS = $(CPPFLAGS) -D_DEBUG
+
+libtuscany_sca_ws_service_la_LIBADD = \
+ -L${TUSCANY_SDOCPP}/lib -ltuscany_sdo -ltuscany_sdo_axiom \
+ -L$(top_builddir)/runtime/core/src -ltuscany_sca \
+ -L$(AXIS2C_HOME)/lib \
+ -laxis2_util \
+ -laxis2_axiom \
+ -laxis2_wsdl \
+ -laxis2_engine \
+ -laxis2_parser \
+ -lpthread \
+ -laxis2_minizip \
+ -laxis2_http_sender \
+ -laxis2_http_receiver
+
+
+INCLUDES = -I$(top_builddir)/runtime/core/src \
+ -I${TUSCANY_SDOCPP}/include \
+ -I${AXIS2C_HOME}/include
+