summaryrefslogtreecommitdiffstats
path: root/sdo-cpp/trunk/runtime/core/src/commonj/sdo/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sdo-cpp/trunk/runtime/core/src/commonj/sdo/Makefile.am')
-rw-r--r--sdo-cpp/trunk/runtime/core/src/commonj/sdo/Makefile.am104
1 files changed, 104 insertions, 0 deletions
diff --git a/sdo-cpp/trunk/runtime/core/src/commonj/sdo/Makefile.am b/sdo-cpp/trunk/runtime/core/src/commonj/sdo/Makefile.am
new file mode 100644
index 0000000000..bc5ecce789
--- /dev/null
+++ b/sdo-cpp/trunk/runtime/core/src/commonj/sdo/Makefile.am
@@ -0,0 +1,104 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+lib_LTLIBRARIES = libtuscany_sdo.la
+
+libtuscany_sdo_la_SOURCES = \
+ ChangedDataObjectListImpl.cpp \
+ ChangeSummaryBuilder.cpp \
+ ChangeSummary.cpp \
+ ChangeSummaryImpl.cpp \
+ CopyHelper.cpp \
+ DASProperty.cpp \
+ DASType.cpp \
+ DASValue.cpp \
+ DASValues.cpp \
+ DataFactory.cpp \
+ DataFactoryImpl.cpp \
+ DataGraph.cpp \
+ DataGraphImpl.cpp \
+ DataObject.cpp \
+ DataObjectImpl.cpp \
+ DataObjectList.cpp \
+ DataObjectListImpl.cpp \
+ DataTypeInfo.cpp \
+ DefaultLogWriter.cpp \
+ EqualityHelper.cpp \
+ GroupDefinition.cpp \
+ GroupEvent.cpp \
+ HelperProvider.cpp \
+ Logger.cpp \
+ LogWriter.cpp \
+ ParserErrorSetter.cpp \
+ Property.cpp \
+ PropertyDefinition.cpp \
+ PropertyDefinitionImpl.cpp \
+ PropertyImpl.cpp \
+ PropertyList.cpp \
+ PropertySetting.cpp \
+ RefCountingObject.cpp \
+ RefCountingPointer.cpp \
+ SAX2Attribute.cpp \
+ SAX2Attributes.cpp \
+ SAX2Namespaces.cpp \
+ SAX2Parser.cpp \
+ SchemaInfo.cpp \
+ SdoCheck.cpp \
+ SDODataConverter.cpp \
+ SDODate.cpp \
+ SdoRuntime.cpp \
+ SDORuntimeException.cpp \
+ SDOSAX2Parser.cpp \
+ SDOSchemaSAX2Parser.cpp \
+ SDOUtils.cpp \
+ SDOValue.cpp \
+ SDOXMLBufferWriter.cpp \
+ SDOXMLFileWriter.cpp \
+ SDOXMLStreamWriter.cpp \
+ SDOXMLString.cpp \
+ SDOXMLWriter.cpp \
+ SDOXSDBufferWriter.cpp \
+ SDOXSDFileWriter.cpp \
+ SDOXSDStreamWriter.cpp \
+ SDOXSDWriter.cpp \
+ Sequence.cpp \
+ SequenceImpl.cpp \
+ Setting.cpp \
+ SettingList.cpp \
+ Type.cpp \
+ TypeDefinition.cpp \
+ TypeDefinitions.cpp \
+ TypeDefinitionImpl.cpp \
+ TypeDefinitionsImpl.cpp \
+ TypeImpl.cpp \
+ TypeList.cpp \
+ XMLDocument.cpp \
+ XMLDocumentImpl.cpp \
+ XMLHelper.cpp \
+ XMLHelperImpl.cpp \
+ XMLQName.cpp \
+ XpathHelper.cpp \
+ XSDHelper.cpp \
+ XSDHelperImpl.cpp \
+ XSDPropertyInfo.cpp \
+ XSDTypeInfo.cpp
+
+libtuscany_sdo_la_LIBADD = -L${LIBXML2_LIB} -lxml2
+
+INCLUDES = -I$(top_builddir)/runtime/core/src \
+ -I${LIBXML2_INCLUDE}
+