summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/unmaintained/modules/json/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sca-cpp/trunk/unmaintained/modules/json/Makefile.am')
-rw-r--r--sca-cpp/trunk/unmaintained/modules/json/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/sca-cpp/trunk/unmaintained/modules/json/Makefile.am b/sca-cpp/trunk/unmaintained/modules/json/Makefile.am
new file mode 100644
index 0000000000..70352f047b
--- /dev/null
+++ b/sca-cpp/trunk/unmaintained/modules/json/Makefile.am
@@ -0,0 +1,29 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+if WANT_JS
+
+incl_HEADERS = *.hpp
+incldir = $(prefix)/include/modules/json
+
+json_test_SOURCES = json-test.cpp
+json_test_LDFLAGS = -lmozjs
+
+noinst_PROGRAMS = json-test
+TESTS = json-test
+
+endif