summaryrefslogtreecommitdiffstats
path: root/sca-cpp/tags/native-sca-1.0.incubating-M3/test/ws.service.interop/ws.service.interop.client/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sca-cpp/tags/native-sca-1.0.incubating-M3/test/ws.service.interop/ws.service.interop.client/Makefile.am')
-rw-r--r--sca-cpp/tags/native-sca-1.0.incubating-M3/test/ws.service.interop/ws.service.interop.client/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/sca-cpp/tags/native-sca-1.0.incubating-M3/test/ws.service.interop/ws.service.interop.client/Makefile.am b/sca-cpp/tags/native-sca-1.0.incubating-M3/test/ws.service.interop/ws.service.interop.client/Makefile.am
new file mode 100644
index 0000000000..9fef007b19
--- /dev/null
+++ b/sca-cpp/tags/native-sca-1.0.incubating-M3/test/ws.service.interop/ws.service.interop.client/Makefile.am
@@ -0,0 +1,51 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+deploydir=$(prefix)/test/ws.service.interop/deploy
+prgbindir=$(deploydir)/bin
+
+prgbin_PROGRAMS = ws.service.interop.client
+prgbin_SCRIPTS = runclient.sh
+EXTRA_DIST = runclient.sh
+
+AM_CPPFLAGS = $(CPPFLAGS)
+
+ws_service_interop_client_SOURCES = \
+TestClient.cpp
+
+ws_service_interop_client_LDADD = \
+-L$(TUSCANY_SCACPP)/lib \
+ -ltuscany_sca \
+-L$(TUSCANY_SDOCPP)/lib \
+ -ltuscany_sdo \
+ -ltuscany_sdo_axiom \
+-L$(AXIS2C_HOME)/lib \
+ -laxis2_util \
+ -laxis2_axiom \
+ -laxis2_wsdl \
+ -laxis2_engine \
+ -laxis2_parser \
+ -laxis2_minizip \
+ -lpthread \
+ -laxis2_http_sender \
+ -laxis2_http_receiver
+
+INCLUDES = \
+-I${AXIS2C_HOME}/include \
+-I${TUSCANY_SCACPP}/include \
+-I${TUSCANY_SDOCPP}/include
+