summaryrefslogtreecommitdiffstats
path: root/sca-cpp/tags/cpp-stable-20060304/sca/runtime/core/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sca-cpp/tags/cpp-stable-20060304/sca/runtime/core/test/Makefile.am')
-rw-r--r--sca-cpp/tags/cpp-stable-20060304/sca/runtime/core/test/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/sca-cpp/tags/cpp-stable-20060304/sca/runtime/core/test/Makefile.am b/sca-cpp/tags/cpp-stable-20060304/sca/runtime/core/test/Makefile.am
new file mode 100644
index 0000000000..05516bac23
--- /dev/null
+++ b/sca-cpp/tags/cpp-stable-20060304/sca/runtime/core/test/Makefile.am
@@ -0,0 +1,20 @@
+SUBDIRS = CustomerInfo MyValue src
+
+BUILT_SOURCES = scagen
+
+scagen:
+ cp ./MyValue/MyValue.h ./testSCASystem/modules/MyValueServiceModule
+ cp ./MyValue/MyValueImpl.h ./testSCASystem/modules/MyValueServiceModule
+ cp ./MyValue/StockQuoteService.h ./testSCASystem/modules/MyValueServiceModule
+ cp ./CustomerInfo/CustomerInfo.h ./testSCASystem/modules/MyValueServiceModule
+ cp ./CustomerInfo/CustomerInfoImpl.h ./testSCASystem/modules/MyValueServiceModule
+ cd $(top_builddir)/bin && \
+ ./scagen.sh -dir ../runtime/core/test/testSCASystem/modules/MyValueServiceModule -output ../runtime/core/test/tmp
+ cp tmp/CustomerInfoImpl*.* CustomerInfo
+ cp tmp/MyValueImpl*.* MyValue
+
+
+install-exec-local:
+ cp CustomerInfo/.libs/libCustomerInfo.so testSCASystem/modules/MyValueServiceModule
+ cp MyValue/.libs/libMyValue.so testSCASystem/modules/MyValueServiceModule
+ \ No newline at end of file