summaryrefslogtreecommitdiffstats
path: root/sca-cpp/tags/cpp-0.1.incubating-M1-final/sca/runtime/core/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sca-cpp/tags/cpp-0.1.incubating-M1-final/sca/runtime/core/test/Makefile.am')
-rw-r--r--sca-cpp/tags/cpp-0.1.incubating-M1-final/sca/runtime/core/test/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/sca-cpp/tags/cpp-0.1.incubating-M1-final/sca/runtime/core/test/Makefile.am b/sca-cpp/tags/cpp-0.1.incubating-M1-final/sca/runtime/core/test/Makefile.am
new file mode 100644
index 0000000000..52ea80e3fb
--- /dev/null
+++ b/sca-cpp/tags/cpp-0.1.incubating-M1-final/sca/runtime/core/test/Makefile.am
@@ -0,0 +1,28 @@
+SUBDIRS = CustomerInfo MyValue src
+
+EXTRA_DIST = testSCASystem/subsystems \
+testSCASystem/modules/MyValueServiceModule/sca.module \
+testSCASystem/modules/MyValueServiceModule/*.fragment \
+testSCASystem/modules/MyValueServiceModule/*.componentType \
+testSCASystem/modules/MyValueServiceModule/*.wsdl \
+testSCASystem/modules/MyValueServiceModule/*.xsd \
+testSCASystem/modules/MyValueServiceModule/*.config
+
+
+BUILT_SOURCES = scagen
+
+scagen:
+ cp ./MyValue/MyValue.h ./testSCASystem/modules/MyValueServiceModule
+ cp ./MyValue/MyValueImpl.h ./testSCASystem/modules/MyValueServiceModule
+ cp ./MyValue/StockQuoteService.h ./testSCASystem/modules/MyValueServiceModule
+ cp ./CustomerInfo/CustomerInfo.h ./testSCASystem/modules/MyValueServiceModule
+ cp ./CustomerInfo/CustomerInfoImpl.h ./testSCASystem/modules/MyValueServiceModule
+ java -jar $(top_builddir)/tools/scagen/bld/scagen.jar -dir testSCASystem/modules/MyValueServiceModule -output tmp
+ cp tmp/CustomerInfoImpl*.* CustomerInfo
+ cp tmp/MyValueImpl*.* MyValue
+
+
+install-exec-local:
+ cp CustomerInfo/.libs/libCustomerInfo.so testSCASystem/modules/MyValueServiceModule
+ cp MyValue/.libs/libMyValue.so testSCASystem/modules/MyValueServiceModule
+ \ No newline at end of file