summaryrefslogtreecommitdiffstats
path: root/sca-cpp/tags/cpp-0.1.incubating-M1-final/sca/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sca-cpp/tags/cpp-0.1.incubating-M1-final/sca/Makefile.am')
-rw-r--r--sca-cpp/tags/cpp-0.1.incubating-M1-final/sca/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/sca-cpp/tags/cpp-0.1.incubating-M1-final/sca/Makefile.am b/sca-cpp/tags/cpp-0.1.incubating-M1-final/sca/Makefile.am
new file mode 100644
index 0000000000..3fd18bc820
--- /dev/null
+++ b/sca-cpp/tags/cpp-0.1.incubating-M1-final/sca/Makefile.am
@@ -0,0 +1,36 @@
+SUBDIRS = tools runtime
+DIST_SUBDIRS = tools runtime samples
+datadir=$(prefix)
+
+data_DATA = INSTALL README LICENSE COPYING NOTICE GettingStarted.html
+nobase_data_DATA = xsd/*.*
+EXTRA_DIST = LICENSE COPYING INSTALL README NOTICE GettingStarted.html scatest.sh xsd doc
+dist-hook:
+ rm -rf `find $(distdir)/ -type d -name .svn`
+ rm -rf `find $(distdir)/ -type d -name .deps`
+
+install-data-hook:
+ rm -rf $(prefix)/samples
+ cp -r samples $(prefix)
+ rm -rf `find $(prefix)/samples -type d -name .svn`
+ rm -rf `find $(prefix)/samples -type d -name .deps`
+ rm -rf $(prefix)/doc
+ cp -r doc $(prefix)
+ rm -rf `find $(prefix)/doc -type d -name .svn`
+ rm -rf `find $(prefix)/doc -type d -name .deps`
+
+
+bindist: dist
+ rm -rf ${PACKAGE}-${PACKAGE_VERSION}
+ rm -rf ${PACKAGE}-${PACKAGE_VERSION}-src
+ rm -rf ${PACKAGE}-${PACKAGE_VERSION}-bin
+ gunzip -f ${PACKAGE}-${PACKAGE_VERSION}.tar.gz
+ tar -xf ${PACKAGE}-${PACKAGE_VERSION}.tar
+ mv ${PACKAGE}-${PACKAGE_VERSION} ${PACKAGE}-${PACKAGE_VERSION}-src
+ tar -cf - ${PACKAGE}-${PACKAGE_VERSION}-src | gzip -c > ${PACKAGE}-${PACKAGE_VERSION}-src.tar.gz
+ cd ${PACKAGE}-${PACKAGE_VERSION}-src \
+ && sh ../makebindist.sh
+ mkdir ${PACKAGE}-${PACKAGE_VERSION}-bin
+ cp -r ${PACKAGE}-${PACKAGE_VERSION}-src/deploy/* ${PACKAGE}-${PACKAGE_VERSION}-bin
+ tar -cf - ${PACKAGE}-${PACKAGE_VERSION}-bin | gzip -c > ${PACKAGE}-${PACKAGE_VERSION}-bin.tar.gz
+