summaryrefslogtreecommitdiffstats
path: root/sca-cpp/branches/lightweight-sca/samples/store-cpp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sca-cpp/branches/lightweight-sca/samples/store-cpp/Makefile.am')
-rw-r--r--sca-cpp/branches/lightweight-sca/samples/store-cpp/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/sca-cpp/branches/lightweight-sca/samples/store-cpp/Makefile.am b/sca-cpp/branches/lightweight-sca/samples/store-cpp/Makefile.am
new file mode 100644
index 0000000000..3f9d8e87eb
--- /dev/null
+++ b/sca-cpp/branches/lightweight-sca/samples/store-cpp/Makefile.am
@@ -0,0 +1,40 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+
+dist_sample_SCRIPTS = start stop ssl-start
+sampledir = $(prefix)/samples/store-cpp
+
+nobase_dist_sample_DATA = currency-converter.cpp fruits-catalog.cpp shopping-cart.cpp store.composite htdocs/*.html
+
+sample_LTLIBRARIES = libcurrency-converter.la libfruits-catalog.la libshopping-cart.la
+noinst_DATA = libcurrency-converter${libsuffix} libfruits-catalog${libsuffix} libshopping-cart${libsuffix}
+
+libcurrency_converter_la_SOURCES = currency-converter.cpp
+libcurrency-converter${libsuffix}:
+ ln -s .libs/libcurrency-converter${libsuffix}
+
+libfruits_catalog_la_SOURCES = fruits-catalog.cpp
+libfruits-catalog${libsuffix}:
+ ln -s .libs/libfruits-catalog${libsuffix}
+
+libshopping_cart_la_SOURCES = shopping-cart.cpp
+libshopping-cart${libsuffix}:
+ ln -s .libs/libshopping-cart${libsuffix}
+
+dist_noinst_SCRIPTS = server-test
+TESTS = server-test