summaryrefslogtreecommitdiffstats
path: root/sca-cpp/branches/lightweight-sca/samples/relay-gae/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sca-cpp/branches/lightweight-sca/samples/relay-gae/Makefile.am')
-rw-r--r--sca-cpp/branches/lightweight-sca/samples/relay-gae/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/sca-cpp/branches/lightweight-sca/samples/relay-gae/Makefile.am b/sca-cpp/branches/lightweight-sca/samples/relay-gae/Makefile.am
new file mode 100644
index 0000000000..7b24ddde27
--- /dev/null
+++ b/sca-cpp/branches/lightweight-sca/samples/relay-gae/Makefile.am
@@ -0,0 +1,40 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+if WANT_PYTHON
+if WANT_GAE
+
+dist_sample_SCRIPTS = start stop
+sampledir = $(prefix)/samples/relay-gae
+
+BUILT_SOURCES = target.stamp
+target.stamp: app.yaml *.py *.composite $(top_builddir)/modules/wsgi/*.py htdocs/*.html
+ mkdir -p target
+ cp app.yaml *.py *.composite `ls $(top_builddir)/modules/wsgi/*.py | grep -v "\-test"` target
+ mkdir -p target/htdocs
+ cp -R htdocs/* target/htdocs
+ touch target.stamp
+
+clean-local:
+ rm -rf target.stamp target
+
+nobase_sample_DATA = target/app.yaml target/*.py target/*.composite target/htdocs/*.html
+
+EXTRA_DIST = app.yaml *.composite *.py htdocs/*.html
+
+endif
+endif