summaryrefslogtreecommitdiffstats
path: root/sca-cpp/branches/lightweight-sca/modules/scheme/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sca-cpp/branches/lightweight-sca/modules/scheme/Makefile.am')
-rw-r--r--sca-cpp/branches/lightweight-sca/modules/scheme/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/sca-cpp/branches/lightweight-sca/modules/scheme/Makefile.am b/sca-cpp/branches/lightweight-sca/modules/scheme/Makefile.am
new file mode 100644
index 0000000000..130fe14303
--- /dev/null
+++ b/sca-cpp/branches/lightweight-sca/modules/scheme/Makefile.am
@@ -0,0 +1,47 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+incl_HEADERS = *.hpp
+incldir = $(prefix)/include/modules/scheme
+
+moddir = $(prefix)/modules/scheme
+
+scheme_test_SOURCES = scheme-test.cpp
+
+scheme_shell_SOURCES = scheme-shell.cpp
+
+value_element_SOURCES = value-element.cpp
+value_element_LDFLAGS =
+
+element_value_SOURCES = element-value.cpp
+element_value_LDFLAGS =
+
+xml_value_SOURCES = xml-value.cpp
+xml_value_LDFLAGS = -lxml2
+
+value_xml_SOURCES = value-xml.cpp
+value_xml_LDFLAGS = -lxml2
+
+json_value_SOURCES = json-value.cpp
+json_value_LDFLAGS = -lmozjs
+
+value_json_SOURCES = value-json.cpp
+value_json_LDFLAGS = -lmozjs
+
+noinst_PROGRAMS = scheme-test
+mod_PROGRAMS = scheme-shell element-value value-element xml-value value-xml json-value value-json
+TESTS = scheme-test