summaryrefslogtreecommitdiffstats
path: root/sca-cpp/branches/cpp-contrib/modules/server/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sca-cpp/branches/cpp-contrib/modules/server/Makefile.am')
-rw-r--r--sca-cpp/branches/cpp-contrib/modules/server/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/sca-cpp/branches/cpp-contrib/modules/server/Makefile.am b/sca-cpp/branches/cpp-contrib/modules/server/Makefile.am
new file mode 100644
index 0000000000..9c18b45dad
--- /dev/null
+++ b/sca-cpp/branches/cpp-contrib/modules/server/Makefile.am
@@ -0,0 +1,39 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+noinst_PROGRAMS = client-test
+
+libdir=$(prefix)/lib
+lib_LTLIBRARIES = libmod_tuscany_eval.la libmod_tuscany_wiring.la
+
+INCLUDES = -I${HTTPD_INCLUDE}
+
+libmod_tuscany_eval_la_SOURCES = mod-eval.cpp
+libmod_tuscany_eval_la_LDFLAGS = -lxml2 -lcurl -lmozjs
+
+libmod_tuscany_wiring_la_SOURCES = mod-wiring.cpp
+libmod_tuscany_wiring_la_LDFLAGS = -lxml2 -lcurl -lmozjs
+
+testdir=$(prefix)/test
+test_LTLIBRARIES = libimpl-test.la
+
+libimpl_test_la_SOURCES = impl-test.cpp
+
+client_test_SOURCES = client-test.cpp
+client_test_LDFLAGS = -lxml2 -lcurl -lmozjs
+
+TESTS = httpd-test server-test wiring-test