summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/modules/http/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-03-01 09:59:18 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-03-01 09:59:18 +0000
commit99af35834fb7655f090af2a3ec01d09d3aa3f69c (patch)
treecee868b609e1e43ec9f2cab9b56bb36388b98ced /sca-cpp/trunk/modules/http/Makefile.am
parentedc5e5d1f4d00bb499606e92bada758e821dca15 (diff)
Minor fixes to distro build. Added missing scripts. Placed libraries in the correct module and component directories.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@917438 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/modules/http/Makefile.am')
-rw-r--r--sca-cpp/trunk/modules/http/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/sca-cpp/trunk/modules/http/Makefile.am b/sca-cpp/trunk/modules/http/Makefile.am
index b522113423..6d477c2946 100644
--- a/sca-cpp/trunk/modules/http/Makefile.am
+++ b/sca-cpp/trunk/modules/http/Makefile.am
@@ -15,17 +15,18 @@
# specific language governing permissions and limitations
# under the License.
-noinst_PROGRAMS = curl-test
-
INCLUDES = -I${HTTPD_INCLUDE}
-httpdir=$(prefix)/modules/http
-http_DATA = httpd.prefix
+moddir=$(prefix)/modules/http
+mod_SCRIPTS = httpd-conf httpd-start httpd-stop httpd-restart
curl_test_SOURCES = curl-test.cpp
curl_test_LDFLAGS = -lxml2 -lcurl -lmozjs
+prefix_DATA = httpd.prefix
+prefixdir=$(prefix)/modules/http
httpd.prefix: $(top_builddir)/config.status
echo ${HTTPD_PREFIX} >httpd.prefix
+noinst_PROGRAMS = curl-test
TESTS = httpd-test http-test