summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/configure.ac
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-09-15 05:08:05 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-09-15 05:08:05 +0000
commitfe52f0dc5830614a303ab0531488a02c026edbc1 (patch)
tree2d8f5009e8bd29e91f294938bd97db307697f5af /sca-cpp/trunk/configure.ac
parent911db2d64f7af7b845bb795db2ed09abd9be2e09 (diff)
Upgrade build scripts to on Ubuntu 10.04.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@997186 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/configure.ac')
-rw-r--r--sca-cpp/trunk/configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/sca-cpp/trunk/configure.ac b/sca-cpp/trunk/configure.ac
index 6f69a60e7b..bb57b49b20 100644
--- a/sca-cpp/trunk/configure.ac
+++ b/sca-cpp/trunk/configure.ac
@@ -229,13 +229,19 @@ xulrunner=`ls /usr/include | grep "xulrunner" | tail -1`
if test "$xulrunner" = ""; then
xulrunner="xulrunner-1.9.1.8"
fi
+xulunstable=`ls /usr/include/$xulrunner | grep "unstable"`
+if test "$xulunstable" = ""; then
+ xulinclude="$xulrunner"
+else
+ xulinclude="$xulrunner/unstable"
+fi
AC_ARG_WITH([js-include], [AC_HELP_STRING([--with-js-include=PATH], [path to installed SpiderMonkey include dir
- [default=/usr/include/$xulrunner/unstable]])], [
+ [default=/usr/include/$xulinclude]])], [
JS_INCLUDE="${withval}"
AC_MSG_RESULT("${withval}")
], [
- JS_INCLUDE="/usr/include/$xulrunner/unstable"
- AC_MSG_RESULT(/usr/include/$xulrunner/unstable)
+ JS_INCLUDE="/usr/include/$xulinclude"
+ AC_MSG_RESULT(/usr/include/$xulinclude)
])
AC_MSG_CHECKING([for js-lib])
AC_ARG_WITH([js-lib], [AC_HELP_STRING([--with-js-lib=PATH], [path to installed SpiderMonkey lib dir [default=/usr/lib/$xulrunner]])], [