summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/configure.ac
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2011-06-13 07:57:06 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2011-06-13 07:57:06 +0000
commiteb7ad1a0241d049f10c9e62a8eb4d9e1dd3000a9 (patch)
tree0284fdb498571add89832977f6875a44557608e2 /sca-cpp/trunk/configure.ac
parentc53f08af43a87119f9307fe7bc48303299c9beed (diff)
Add configuration and script to enable mod-security 2.6.0.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@1135046 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/configure.ac')
-rw-r--r--sca-cpp/trunk/configure.ac35
1 files changed, 34 insertions, 1 deletions
diff --git a/sca-cpp/trunk/configure.ac b/sca-cpp/trunk/configure.ac
index 4d713a5c93..49c7c3e663 100644
--- a/sca-cpp/trunk/configure.ac
+++ b/sca-cpp/trunk/configure.ac
@@ -507,7 +507,7 @@ if test "${want_openid}" = "true"; then
# Configure path to mod-auth-openid
AC_MSG_CHECKING([for mod-auth-openid])
- AC_ARG_WITH([mod-auth-openid], [AC_HELP_STRING([--with-mod-auth-openid=PATH], [path to installed mod-auth-openid [default=/usr]])], [
+ AC_ARG_WITH([mod-auth-openid], [AC_HELP_STRING([--with-mod-auth-openid=PATH], [path to installed mod-auth-openid [default=/usr/local]])], [
MODAUTHOPENID_PREFIX="${withval}"
AC_MSG_RESULT("${withval}")
], [
@@ -561,6 +561,39 @@ else
AM_CONDITIONAL([WANT_OAUTH], false)
fi
+# Enable support for modsecurity.
+AC_MSG_CHECKING([whether to enable mod-security support])
+AC_ARG_ENABLE(mod-security, [AS_HELP_STRING([--enable-mod-security], [enable mod-security support [default=no]])],
+[ case "${enableval}" in
+ no)
+ AC_MSG_RESULT(no)
+ ;;
+ *)
+ AC_MSG_RESULT(yes)
+ want_modsecurity=true
+ ;;
+ esac ],
+[ AC_MSG_RESULT(no)])
+if test "${want_modsecurity}" = "true"; then
+
+ # Configure path to mod-security
+ AC_MSG_CHECKING([for mod-security])
+ AC_ARG_WITH([mod-security], [AC_HELP_STRING([--with-mod-security=PATH], [path to installed mod-security [default=/usr/local]])], [
+ MODSECURITY_PREFIX="${withval}"
+ AC_MSG_RESULT("${withval}")
+ ], [
+ MODSECURITY_PREFIX="/usr/local/"
+ AC_MSG_RESULT(/usr/local)
+ ])
+ AC_SUBST(MODSECURITY_PREFIX)
+
+ AM_CONDITIONAL([WANT_MODSECURITY], true)
+ AC_DEFINE([WANT_MODSECURITY], 1, [enable mod-security support])
+
+else
+ AM_CONDITIONAL([WANT_MODSECURITY], false)
+fi
+
# Enable support for Google AppEngine.
AC_MSG_CHECKING([whether to enable Google AppEngine support])
AC_ARG_ENABLE(gae, [AS_HELP_STRING([--enable-gae], [enable Google AppEngine support [default=no]])],