summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/configure.ac
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-05-29 19:44:35 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-05-29 19:44:35 +0000
commite5a49fff24c79431782da107185431b7835ef492 (patch)
tree8bb6ca1aaad4fed82443dcb7d420533c31eb3eb4 /sca-cpp/trunk/configure.ac
parent7eef73b80c5f6c4f34f57cc48a46383689acecca (diff)
Fix distribution build, add missing files and samples and fix path to libraries. GCC 4.5 is used if available but not installed automatically.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@949435 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/configure.ac')
-rw-r--r--sca-cpp/trunk/configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/sca-cpp/trunk/configure.ac b/sca-cpp/trunk/configure.ac
index 11f57ca008..cf53734b25 100644
--- a/sca-cpp/trunk/configure.ac
+++ b/sca-cpp/trunk/configure.ac
@@ -25,19 +25,20 @@ AM_CONFIG_HEADER(config.h)
AM_INIT_AUTOMAKE([tar-ustar])
AC_PREFIX_DEFAULT(/usr/local/tuscany/sca)
-# Require GCC 4.5
+# Check for required programs.
+AC_MSG_NOTICE([checking for programs])
AC_MSG_CHECKING([for gcc-4.5])
-if test -x "/usr/bin/gcc-4.5"; then
+if test -x "/usr/bin/g++-4.5"; then
+ # Use GCC 4.5 if available
CXX=/usr/bin/g++-4.5
CPP=/usr/bin/cpp-4.5
CC=/usr/bin/gcc-4.5
AC_MSG_RESULT(/usr/bin/gcc-4.5)
+ AM_CONDITIONAL([WANT_GCC45], true)
+ AC_DEFINE([WANT_GCC45], 1, [compile with gcc-4.5])
else
- AC_MSG_ERROR([could not find gcc-4.5])
+ AM_CONDITIONAL([WANT_GCC45], false)
fi
-
-# Check for required programs.
-AC_MSG_NOTICE([checking for programs])
AC_PROG_CXX
AC_PROG_AWK
AC_PROG_CC