summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/configure.ac
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-05-16 21:08:34 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-05-16 21:08:34 +0000
commita0e624622f7ea40d15449e3531e22d1eece3fb74 (patch)
treec02380746ffc1749ce6d3c59367131aa3831cadb /sca-cpp/trunk/configure.ac
parent6d5c215d67b5c71e04f0ec299edfb5a9940a003e (diff)
Add Apache Libcloud support to the build.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@944912 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/configure.ac')
-rw-r--r--sca-cpp/trunk/configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/sca-cpp/trunk/configure.ac b/sca-cpp/trunk/configure.ac
index 58c516c3ee..5791dd5e19 100644
--- a/sca-cpp/trunk/configure.ac
+++ b/sca-cpp/trunk/configure.ac
@@ -478,7 +478,17 @@ else
AM_CONDITIONAL([WANT_GAE], false)
fi
-# Configure path to Java includes and lib.
+# Configure path to Apache Libcloud.
+AC_MSG_CHECKING([for libcloud])
+AC_ARG_WITH([libcloud], [AC_HELP_STRING([--with-libcloud=PATH], [path to installed Apache Libcloud [default=/usr/local]])], [
+ LIBCLOUD_LIB="${withval}/lib/python"
+ AC_MSG_RESULT("${withval}")
+], [
+ LIBCLOUD_LIB="/usr/local/lib/python2.6/site-packages"
+ AC_MSG_RESULT(/usr/local)
+])
+AC_SUBST(LIBCLOUD_LIB)
+
# Configure path to Apache Axis2C includes and lib.
AC_MSG_CHECKING([for axis2c])
AC_ARG_WITH([axis2c], [AC_HELP_STRING([--with-axis2c=PATH], [path to installed Apache Axis2C [default=/usr/local/axis2c]])], [