summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/configure.ac
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2011-03-21 07:42:12 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2011-03-21 07:42:12 +0000
commit312b588bc15de4597b6113613db63f24a6c8734e (patch)
tree75c77f3283f9ef66b302d417e37d0479aaf0960c /sca-cpp/trunk/configure.ac
parent96c58efd10432c163c51d72780cece7dce4b05a9 (diff)
Add debug support to optimized build and downgrade GCC optimizations from O3 to O2.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@1083695 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/configure.ac')
-rw-r--r--sca-cpp/trunk/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/sca-cpp/trunk/configure.ac b/sca-cpp/trunk/configure.ac
index 9a64c78fb6..4d713a5c93 100644
--- a/sca-cpp/trunk/configure.ac
+++ b/sca-cpp/trunk/configure.ac
@@ -110,7 +110,7 @@ if test "${want_maintainer_mode}" = "true"; then
AM_CONDITIONAL([WANT_MAINTAINER_MODE], true)
AC_DEFINE([WANT_MAINTAINER_MODE], 1, [compile with debugging and compile-time warnings])
else
- cxxflags="${cxxflags} -O3 -std=c++0x -fmessage-length=0"
+ cxxflags="${cxxflags} -g -O2 -std=c++0x -fmessage-length=0"
AM_CONDITIONAL([WANT_MAINTAINER_MODE], false)
fi