summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-03-01 09:59:18 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-03-01 09:59:18 +0000
commit99af35834fb7655f090af2a3ec01d09d3aa3f69c (patch)
treecee868b609e1e43ec9f2cab9b56bb36388b98ced /sca-cpp/trunk/Makefile.am
parentedc5e5d1f4d00bb499606e92bada758e821dca15 (diff)
Minor fixes to distro build. Added missing scripts. Placed libraries in the correct module and component directories.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@917438 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/Makefile.am')
-rw-r--r--sca-cpp/trunk/Makefile.am13
1 files changed, 3 insertions, 10 deletions
diff --git a/sca-cpp/trunk/Makefile.am b/sca-cpp/trunk/Makefile.am
index df348fbc3c..3ca481b75c 100644
--- a/sca-cpp/trunk/Makefile.am
+++ b/sca-cpp/trunk/Makefile.am
@@ -17,14 +17,11 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = kernel modules components test doc
+SUBDIRS = kernel modules components test doc samples
datadir=$(prefix)
data_DATA = INSTALL README LICENSE COPYING NOTICE
-nobase_data_DATA = xsd/*.*
-
-DIST_SUBDIRS = kernel modules components test doc samples
-EXTRA_DIST = LICENSE COPYING INSTALL README NOTICE autogen.sh xsd
+nobase_data_DATA = xsd/*.xsd xsd/external/*.xsd xsd/external/*.dtd
install-data-hook:
rm -rf $(prefix)/doc
@@ -32,12 +29,8 @@ install-data-hook:
rm -f $(prefix)/doc/Makefile* $(prefix)/doc/Doxyfile*
rm -rf `find $(prefix)/doc -type d -name .svn`
rm -rf `find $(prefix)/doc -type d -name .deps`
+ rm -rf $(prefix)/test
- rm -rf $(prefix)/samples
- cp -r samples $(prefix)
- rm -rf `find $(prefix)/samples -type d -name .svn`
- rm -rf `find $(prefix)/samples -type d -name .deps`
-
dist-hook:
rm -rf `find $(distdir)/ -type d -name .svn`
rm -rf `find $(distdir)/ -type d -name .deps`