summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-05-30 03:32:37 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-05-30 03:32:37 +0000
commit90b55b93704adb3e1fac59d58c2d644d37537bc9 (patch)
treec35f9d4d69789ab45343439044daf9849d1eb4ff /sca-cpp/trunk/Makefile.am
parent3cdc93215b4b0be782060438eec8c20b9c5152ce (diff)
Fix source distribution build scripts, add missing files to the dist targets.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@949466 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/Makefile.am')
-rw-r--r--sca-cpp/trunk/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/sca-cpp/trunk/Makefile.am b/sca-cpp/trunk/Makefile.am
index ec79336c2b..75e5e7e1ac 100644
--- a/sca-cpp/trunk/Makefile.am
+++ b/sca-cpp/trunk/Makefile.am
@@ -17,15 +17,17 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = kernel modules components doc samples
+SUBDIRS = etc kernel modules components samples doc ubuntu
datadir=$(prefix)
-data_DATA = README LICENSE COPYING NOTICE
-nobase_data_DATA = xsd/*.xsd xsd/external/*.xsd xsd/external/*.dtd
+dist_data_DATA = README LICENSE COPYING NOTICE
+nobase_dist_data_DATA = xsd/*.xsd xsd/external/*.xsd xsd/external/*.dtd
+EXTRA_DIST = INSTALL bootstrap
dist-hook:
rm -rf `find $(distdir)/ -type d -name .svn`
rm -rf `find $(distdir)/ -type d -name .deps`
+ rm -rf $(distdir)/.git
bindist: install
rm -rf ${PACKAGE}-${PACKAGE_VERSION}-bin