summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/components/chat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sca-cpp/trunk/components/chat/Makefile.am')
-rw-r--r--sca-cpp/trunk/components/chat/Makefile.am17
1 files changed, 11 insertions, 6 deletions
diff --git a/sca-cpp/trunk/components/chat/Makefile.am b/sca-cpp/trunk/components/chat/Makefile.am
index ea63a475e2..11e3179e8a 100644
--- a/sca-cpp/trunk/components/chat/Makefile.am
+++ b/sca-cpp/trunk/components/chat/Makefile.am
@@ -17,15 +17,20 @@
if WANT_CHAT
-INCLUDES = -I${LIBSTROPHE_INCLUDE}
+noinst_PROGRAMS = xmpp-test client-test
+
+INCLUDES = -I${LIBSTROPHE_INCLUDE} -I${LIBSTROPHE_INCLUDE}/src
compdir=$(prefix)/components/chat
-comp_LTLIBRARIES = libchat-sender.la libchat-listener.la
+comp_LTLIBRARIES = libchatter.la
+
+libchatter_la_SOURCES = chatter.cpp
+libchatter_la_LDFLAGS = -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lexpat -lssl -lresolv
-libchat_sender_la_SOURCES = chat-sender.cpp
-libchat_sender_la_LDFLAGS = -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lexpat -lssl -lresolv
+xmpp_test_SOURCES = xmpp-test.cpp
+xmpp_test_LDFLAGS = -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lexpat -lssl -lresolv
-libchat_listener_la_SOURCES = chat-listener.cpp
-libchat_listener_la_LDFLAGS = -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lexpat -lssl -lresolv
+client_test_SOURCES = client-test.cpp
+client_test_LDFLAGS = -lxml2 -lcurl -lmozjs -L${LIBSTROPHE_LIB} -R${LIBSTROPHE_LIB} -lstrophe -lexpat -lssl -lresolv
endif