summaryrefslogtreecommitdiffstats
path: root/cpp/sca/modules/http/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--cpp/sca/modules/http/Makefile.am (renamed from cpp/sca/modules/httpd/Makefile.am)10
1 files changed, 9 insertions, 1 deletions
diff --git a/cpp/sca/modules/httpd/Makefile.am b/cpp/sca/modules/http/Makefile.am
index 13cb3045f6..d34da0822f 100644
--- a/cpp/sca/modules/httpd/Makefile.am
+++ b/cpp/sca/modules/http/Makefile.am
@@ -15,10 +15,18 @@
# specific language governing permissions and limitations
# under the License.
+noinst_PROGRAMS = curl-test
+
libdir=$(prefix)/lib
lib_LTLIBRARIES = libmod_tuscany.la
-INCLUDES = -I. -I$(top_builddir)/kernel -I${HTTPD_INCLUDE} -I${APR_INCLUDE} -I${LIBXML2_INCLUDE} -I${LIBMOZJS_INCLUDE}
+INCLUDES = -I. -I$(top_builddir)/kernel -I${HTTPD_INCLUDE} -I${APR_INCLUDE} -I${LIBXML2_INCLUDE} -I${LIBMOZJS_INCLUDE} -I${CURL_INCLUDE}
libmod_tuscany_la_SOURCES = mod.cpp
libmod_tuscany_la_LIBADD = -lpthread -L${LIBXML2_LIB} -lxml2 -L${LIBMOZJS_LIB} -lmozjs
+
+curl_test_SOURCES = curl-test.cpp
+curl_test_LDADD = -lpthread -L${LIBXML2_LIB} -lxml2 -L${CURL_LIB} -lcurl
+
+TESTS = httpd-test http-test
+