summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/modules/wsgi/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-03-13 18:40:42 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-03-13 18:40:42 +0000
commit014971ccb5b2041147cf9d84d498cce64ea0493e (patch)
tree0f93393d6a58e6bcd7a1e68bbe8a9c4af3626001 /sca-cpp/trunk/modules/wsgi/Makefile.am
parent7fc75cdf0b19e8f748505931164d1756e796b833 (diff)
Updated the INSTALL instructions, fixed a few incremental build issues, and added a script that builds everything from scratch, tested on Ubuntu 9.10.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@922645 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to '')
-rw-r--r--sca-cpp/trunk/modules/wsgi/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/sca-cpp/trunk/modules/wsgi/Makefile.am b/sca-cpp/trunk/modules/wsgi/Makefile.am
index 9df8135ab2..ed5c868f6b 100644
--- a/sca-cpp/trunk/modules/wsgi/Makefile.am
+++ b/sca-cpp/trunk/modules/wsgi/Makefile.am
@@ -22,6 +22,17 @@ INCLUDES = -I${PYTHON_INCLUDE}
mod_SCRIPTS = composite.py scdl.py util.py elemutil.py xmlutil.py atomutil.py jsonutil.py wsgi-start wsgi-stop
moddir = $(prefix)/modules/wsgi
+noinst_DATA = target.stamp
+
+target.stamp: app.yaml *.py *.composite htdocs/*
+ mkdir -p target
+ cp app.yaml *.py *.composite target
+ cp -R htdocs target/htdocs
+ touch target.stamp
+
+clean-local:
+ rm -rf target.stamp target
+
client_test_SOURCES = client-test.cpp
client_test_LDFLAGS = -lxml2 -lcurl -lmozjs