summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/configure.ac
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-03-15 06:13:25 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-03-15 06:13:25 +0000
commita91627d5b8cc6c79a5a92ff39670a3716eeaa773 (patch)
tree43a3556b0ec94278259ff1829bf8ce8e9247757e /sca-cpp/trunk/configure.ac
parent988e927481f62259e26c54661113b8f9800f89ae (diff)
Fixes to the automated Ubuntu install script, and automatic detection of xulrunner level (as it changes often) in configure.ac.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@923071 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to '')
-rw-r--r--sca-cpp/trunk/configure.ac16
1 files changed, 10 insertions, 6 deletions
diff --git a/sca-cpp/trunk/configure.ac b/sca-cpp/trunk/configure.ac
index 16a5f49bd4..baf9bf9003 100644
--- a/sca-cpp/trunk/configure.ac
+++ b/sca-cpp/trunk/configure.ac
@@ -84,21 +84,25 @@ AC_SUBST(LIBXML2_LIB)
# Configure path to libmozjs includes and lib.
AC_MSG_CHECKING([for js-include])
+xulrunner=`ls /usr/include | grep "xulrunner" | tail -1`
+if test "$xulrunner" = ""; then
+ xulrunner="xulrunner-1.9.1.8"
+fi
AC_ARG_WITH([js-include], [AC_HELP_STRING([--with-js-include=PATH], [path to installed SpiderMonkey include dir
- [default=/usr/include/xulrunner-1.9.1.8/unstable]])], [
+ [default=/usr/include/$xulrunner/unstable]])], [
JS_INCLUDE="${withval}"
AC_MSG_RESULT("${withval}")
], [
- JS_INCLUDE="/usr/include/xulrunner-1.9.1.8/unstable"
- AC_MSG_RESULT(/usr/include/xulrunner-1.9.1.8/unstable)
+ JS_INCLUDE="/usr/include/$xulrunner/unstable"
+ AC_MSG_RESULT(/usr/include/$xulrunner/unstable)
])
AC_MSG_CHECKING([for js-lib])
-AC_ARG_WITH([js-lib], [AC_HELP_STRING([--with-js-lib=PATH], [path to installed SpiderMonkey lib dir [default=/usr/lib/xulrunner-1.9.1.8]])], [
+AC_ARG_WITH([js-lib], [AC_HELP_STRING([--with-js-lib=PATH], [path to installed SpiderMonkey lib dir [default=/usr/lib/$xulrunner]])], [
JS_LIB="${withval}"
AC_MSG_RESULT("${withval}")
], [
- JS_LIB="/usr/lib/xulrunner-1.9.1.8"
- AC_MSG_RESULT(/usr/lib/xulrunner-1.9.1.8)
+ JS_LIB="/usr/lib/$xulrunner"
+ AC_MSG_RESULT(/usr/lib/$xulrunner)
])
AC_SUBST(JS_INCLUDE)
AC_SUBST(JS_LIB)